Running mopidy container fails

Hi all,

I tried to install mopidy in Ubuntu and due to some broken dependencies I decided to search for a dockerized version of it. I found a nice version here

Unfortunately I got some errors when trying to make it work with PulseAudio over the network. I see the following messages:

AL lib: (EE) ALCplaybackAlsa_open: Could not open playback device 'default': No such file or directory
Pipeline is PREROLLING ...
WARNING: from element /GstPipeline:pipeline0/GstAutoAudioSink:autoaudiosink0: Failed to connect: Connection refused
Additional debug info:
pulsesink.c(615): gst_pulseringbuffer_open_device (): /GstPulseSink:autoaudiosink0-actual-sink-pulse
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock

Is this something where you could help me?
Thanks in advance

What command are you using to run the container? I’m not sure about Pulse audio, but in general you have give the container access to whatever’s doing the playback on the host.

This is my command: docker run --rm -e "PULSE_SERVER=tcp:$(hostname -i):4713" -e "PULSE_COOKIE_DATA=$(pax11publish -d | grep --color=never -Po '(?<=^Cookie: ).*')" wernight/mopidy gst-launch-1.0 audiotestsrc ! audioresample ! autoaudiosink
I followed the recommendations to enable PulseAudio over network from the container’s creator but didn’t help.