"Unit mopidy.service entered failed state" after update to 2.0

I was using modipy (Version 1.1.2) on a RaspberryPi (Raspbian Jessie) as a service. Everything worked fine (except some issues with songs from YouTube). To test if the new update resolves this issues and profit from other changes I updated to mopidy version 2.0 by
sudo pip install --upgrade Mopidy
(I think I should have better used
sudo apt-get update
sudo apt-get dist-upgrade
After the update mopidy stopped working.
Also an update of the gstreamer components by

sudo apt-get install python-gst-1.0 gir1.2-gstreamer-1.0 gir1.2-gst-plugins-base-1.0 gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-tools

didn’t help.
I have Python 2.7.9
I also got the latest python-pip and confirmed that the other components mentioned in the installation manual are up to date by
sudo apt-get install build-essential python-dev python-pip

I also restarted the mopidy service and the whole RaspberryPi. I have all my log files on a ram disk therefore only entries after the reboot are there

sudo journalctl -u mopidy gives
– Logs begin at Tue 2016-02-16 22:56:28 CET, end at Tue 2016-02-16 22:57:14 CET. –
Feb 16 22:56:31 sys systemd[1]: Starting Mopidy music server…
Feb 16 22:56:31 sys systemd[1]: Started Mopidy music server.
Feb 16 22:56:31 sys systemd[1]: mopidy.service: main process exited, code=exited, status=203/EXEC
Feb 16 22:56:31 sys systemd[1]: Unit mopidy.service entered failed state.

/var/log/mopidy/mopidy.log does not exist.
If I look in the syslog for all entries of mopidy I get

Feb 16 22:56:31 sys systemd[1]: Mounting /var/cache/mopidy...
Feb 16 22:56:31 sys systemd[1]: Mounted /var/cache/mopidy.
Feb 16 22:56:31 sys systemd[464]: Failed at step EXEC spawning /usr/bin/mopidy: No such file or directory
Feb 16 22:56:31 sys systemd[1]: mopidy.service: main process exited, code=exited, status=203/EXEC
Feb 16 22:56:31 sys systemd[1]: Unit mopidy.service entered failed state.

/usr/bin/mopidy does not exist (but /usr/local/bin/mopidy does) But what is the reason that it seems to be looking in the wrong place after the update and how can I change this back (I’m not so familiar with this service routines). What (else) should I do to get mopidy running again?

/usr/bin/mopidy is Mopidy installed by APT.

/usr/local/bin/mopidy is Mopidy installed by pip.

I’d start by removing any remnants of your pip install of Mopidy:

sudo pip uninstall mopidy pykka tornado

Then reinstall from APT:

sudo apt-get install --reinstall mopidy

If it still doesn’t work after a sudo systemd restart mopidy, try running it just like the service does, but by hand:

sudo -i -u mopidy /usr/bin/mopidy --config /etc/mopidy/mopidy.conf

That should help you see any errors.

As you told I did
sudo pip uninstall mopidy pykka tornado
sudo apt-get install --reinstall mopidy
gave me only mopidy 1.1.2-1.
sudo apt-get update && sudo apt-get dist-upgrade
I got offered an update of mopidy and libgraphite2-3 and gstreamer1.0-pulseaudio as a new package.

sudo systemd restart mopidy

does not work (“Excess arguments”) but if I use sudo service mopidy restart and then sudo service mopidy status I got an error pkg_resources.DistributionNotFound: The 'Pykka>=1.1' distribution was not found and is required by Mopidy

I’ a bit surprised that this Pykka was not installed with mopidy as well?
Sould I do
sudo pip install Pykka

Sorry, I meant “systemctl”, not “systemd”.

Pykka is installed by APT too. It is almost impossible to trick APT into
installing Mopidy and not Pykka Something is quite wrong on your system,
maybe something related to PYTHONPATH.

Try reinstalling the python-pykka package from APT.

If you get as far as successfully running the “mopidy deps” command, please
include the output here, as it might shine some light on what is wrong.

sudo apt-get install python-pykka
Reading package lists... Done
Building dependency tree
Reading state information... Done
python-pykka is already the newest version.
python-pykka set to manually installed.
The following packages were automatically installed and are no longer required:
  gstreamer0.10-plugins-ugly libdrm-freedreno1 libdrm-nouveau2 libdrm-radeon1 libelf1 libllvm3.5 python-gst0.10 python-libxml2
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

So pykka seems to be already there and just mopidy not finding it…

 find / -name pykka  2>&1 | grep -v "Permission denied" gives


If I run pip list --outdated I get
tornado (3.2.2) - Latest: 4.3 [sdist]
should I update it (by pip or apt)?

No, we support any Tornado version from 2.3 and up, so that’s good.

Pykka seems to be installed just for Python 2.6, which Mopidy hasn’t supported in a very long time. As far as I know, Jessie doesn’t even come with Python 2.6, as 2.7 was released almost six years ago. I’m quite confused here.

I don’t know. I made a fresh installation of Raspbian Jessie only some weeks ago and didn’t do to many changes at the system since then.
The python2.6 directory actually contains almost no content (has only 776KB but Python 2.7 has 87 MB)

 tree -d python2.6/
└── dist-packages
    ├── gst-0.10
    │   └── gst
    │       └── extend
    ├── mcpi
    ├── pykka
    └── Pykka-1.2.1.egg-info

and most of the files are just links to their equivalent in …/…/…/…/share/pyshared/ (true for all files in the pykka and Pykka-1.2.1.egg-info files folders). How can one make Python 2.7 also aware of this pyshared data?

I had the same issue; updated mopidy and would then start in failed state.

Mopidy installed by apitute and running as system service.

Same error, The ‘Pykka>=1.1’ distribution was not found and is required by Mopidy.

Aptitude however confirmed pykka it was installed.
(Sorry I can’t remember if I tried to install it with pip or not)

I had an hour ahead of my and not much else on the raspberry so I did a clean Raspbian install; install went smoothly and it all works fine when installing from scratch.

Before I start thinking about reinstalling the complete Raspberry I tried
sudo pip install -U pykka
wich gave
Collecting pykka
Downloading Pykka-1.2.1-py2.py3-none-any.whl
Installing collected packages: pykka
Successfully installed pykka-1.2.1

Afterwards I had a new folder
and now Mopidy is working again…
I’m not an expert in the difference between pip and apt (/usr/local vs /usr) so I don’t know why it worked and if it is a specific problem of few systems or a general problem of the update process that should be fixed.