Mopidy Discourse

Help with running as service

Hello
It seems I can’t run mopidy as a service. I installed the latest release with pip (sudo python3 -m pip install --upgrade mopidy). It runs fine from a terminal.
The next step would be to add it as a service ( sudo systemctl enable mopidy) but I get “Failed to enable unit: Unit file mopidy.service does not exist.”

I have installed mopidy with apt-get and I can run it as a service but it did not work. The sound modul was crashing and version 2 vas installed

Thank you

The service is only installed with the Debian package which should be installed from apt.mopidy.com as per the instructions at https://docs.mopidy.com/en/latest/installation/debian/#install-from-apt-mopidy-com

Note, you will require Python 3.7+ to run Mopidy 3. Old versions of Ubuntu (e.g. 18.04) are not supported (details).

1 Like

I tried that and it intalls the old wesion of Mopidy
Or is this dependent on the Python version installed?
The version 2 does not work on my pi3. I install it and install the Musicbox and when I try to play a stream it doesn’t work. Even if I kill Mopidy and open lets say youtube the video just keeps loading. Only adter I reebot the Pi sound starts working again. It looks like the sound card freezes. And also Mopidy reports it can’t stream because there is a problem with the URL. But Mopidy 3.1.1 works perfectly

Yes, like I said before, it depends on what version of Python the operating system is using. But if you are running Buster then you should be fine. If you are running something older than Buster then you would need to upgrade. What operating system are you running?

I’m not interested in supporting Mopidy v2.x, it is too old. So let’s figure out why you are unable to install the latest version of Mopidy from apt.mopidy.com. Provide the output from the following command:

apt-cache policy mopidy
1 Like

I uninstalled Python 2 and removed any Mopidy instances and I installed Mooidy again. It worked perfectly.
Niw everything works perfectly so thank you so much for your help!!
:grin:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.