Two errors on Ubuntu 11.04

I am using Mopidy with an older version of MPD, the one in the Ubutu 11.04 repositories. I am getting the following errors when mopidy starts:

ERROR    Extension gmusic failed during setup, this might have left the registry in a bad state.
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/mopidy/", line 145, in main
  File "/usr/local/lib/python2.7/dist-packages/mopidy_gmusic/", line 29, in setup
    from .actor import GMusicBackend
  File "/usr/local/lib/python2.7/dist-packages/mopidy_gmusic/", line 10, in <module>
    from .session import GMusicSession
  File "/usr/local/lib/python2.7/dist-packages/mopidy_gmusic/", line 5, in <module>
    from gmusicapi import Mobileclient, Webclient, CallFailure
  File "/usr/local/lib/python2.7/dist-packages/gmusicapi/", line 4, in <module>
    from gmusicapi.clients import Webclient, Musicmanager, Mobileclient
  File "/usr/local/lib/python2.7/dist-packages/gmusicapi/clients/", line 2, in <module>
    from gmusicapi.clients.musicmanager import Musicmanager, OAUTH_FILEPATH
  File "/usr/local/lib/python2.7/dist-packages/gmusicapi/clients/", line 16, in <module>
    from gmusicapi.protocol import musicmanager, upload_pb2, locker_pb2
  File "/usr/local/lib/python2.7/dist-packages/gmusicapi/protocol/", line 19, in <module>
    from gmusicapi.protocol import upload_pb2, locker_pb2, download_pb2
  File "/usr/local/lib/python2.7/dist-packages/gmusicapi/protocol/", line 10, in <module>
    import locker_pb2
  File "/usr/local/lib/python2.7/dist-packages/gmusicapi/protocol/", line 10, in <module>
    import uits_pb2
  File "/usr/local/lib/python2.7/dist-packages/gmusicapi/protocol/", line 677, in <module>
    DESCRIPTOR.message_types_by_name['ProductId'] = _PRODUCTID
AttributeError: 'FileDescriptor' object has no attribute 'message_types_by_name'
INFO     Starting Mopidy mixer: SoftwareMixer
INFO     Starting Mopidy audio
INFO     Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend, LocalBackend
ERROR    Unhandled exception in Audio (urn:uuid:555ee9f3-940b-4bf0-aa54-3029ce4ef977):
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pykka/", line 192, in _actor_loop
  File "/usr/local/lib/python2.7/dist-packages/mopidy/audio/", line 411, in on_start
  File "/usr/local/lib/python2.7/dist-packages/mopidy/audio/", line 439, in _setup_playbin
    self._signals.connect(playbin, 'source-setup', self._on_source_setup)
  File "/usr/local/lib/python2.7/dist-packages/mopidy/audio/", line 50, in connect
    self._ids[(element, event)] = element.connect(event, func, *args)
TypeError: <__main__.GstPlayBin2 object (playbin20) at 0xafa20cc>: unknown signal name: source-setup
INFO     Loaded 0 M3U playlists from /home/cypress/.local/share/mopidy/m3u

Any ideas how I can fix this?

What do you mean you are using Mopidy with MPD?

There are two errors here, one relating to gmuisc and one relating to audio. I would disable the gmusic extension and concentrate on audio first. You probably need to provide the output of mopidy deps and mopidy config.

mopidy deps

Executable: /usr/local/bin/mopidy
Platform: Linux-2.6.38-8-generic-i686-with-Ubuntu-11.04-natty
Python: CPython 2.7.1+ from /usr/lib/python2.7
Mopidy: 1.1.1 from /usr/local/lib/python2.7/dist-packages
  Pykka>=1.1: 1.2.1 from /usr/local/lib/python2.7/dist-packages
  requests>=2.0: 2.7.0 from /usr/local/lib/python2.7/dist-packages
  setuptools: 18.3.2 from /usr/local/lib/python2.7/dist-packages
  tornado>=2.3: 4.2.1 from /usr/local/lib/python2.7/dist-packages
    backports.ssl-match-hostname: from /usr/local/lib/python2.7/dist-packages
    certifi: 2015.9.6.2 from /usr/local/lib/python2.7/dist-packages
Mopidy-GMusic: 0.3.0 from /usr/local/lib/python2.7/dist-packages
  setuptools: 18.3.2 from /usr/local/lib/python2.7/dist-packages
  Mopidy>=0.18: 1.1.1 from /usr/local/lib/python2.7/dist-packages
    Pykka>=1.1: 1.2.1 from /usr/local/lib/python2.7/dist-packages
    requests>=2.0: 2.7.0 from /usr/local/lib/python2.7/dist-packages
    setuptools: 18.3.2 from /usr/local/lib/python2.7/dist-packages
    tornado>=2.3: 4.2.1 from /usr/local/lib/python2.7/dist-packages
      backports.ssl-match-hostname: from /usr/local/lib/python2.7/dist-packages
      certifi: 2015.9.6.2 from /usr/local/lib/python2.7/dist-packages
  Pykka>=1.1: 1.2.1 from /usr/local/lib/python2.7/dist-packages
  gmusicapi>=3.0.0: 6.0.0 from /usr/local/lib/python2.7/dist-packages
    validictory!=0.9.2,>=0.8.0: 1.0.0 from /usr/local/lib/python2.7/dist-packages
    decorator>=3.3.1: 4.0.2 from /usr/local/lib/python2.7/dist-packages
    mutagen>=1.18: 1.31 from /usr/local/lib/python2.7/dist-packages
    protobuf>=2.4.1: 3.0.0a3 from /usr/local/lib/python2.7/dist-packages
      setuptools: 18.3.2 from /usr/local/lib/python2.7/dist-packages
    requests!=1.2.0,!=2.2.1,>=1.1.0: 2.7.0 from /usr/local/lib/python2.7/dist-packages
    python-dateutil!=2.0,>=1.3: 2.4.2 from /usr/local/lib/python2.7/dist-packages
      six>=1.5: 1.9.0 from /usr/local/lib/python2.7/dist-packages
    proboscis>= from /usr/local/lib/python2.7/dist-packages
    oauth2client>=1.1: 1.5.1 from /usr/local/lib/python2.7/dist-packages
      httplib2>=0.9.1: 0.9.1 from /usr/local/lib/python2.7/dist-packages
      pyasn1>=0.1.7: 0.1.8 from /usr/local/lib/python2.7/dist-packages
      pyasn1-modules>=0.0.5: 0.0.7 from /usr/local/lib/python2.7/dist-packages
        pyasn1>=0.1.8: 0.1.8 from /usr/local/lib/python2.7/dist-packages
      rsa>=3.1.4: 3.2 from /usr/local/lib/python2.7/dist-packages
        pyasn1>=0.1.3: 0.1.8 from /usr/local/lib/python2.7/dist-packages
      six>=1.6.1: 1.9.0 from /usr/local/lib/python2.7/dist-packages
    mock>=0.7.0: 1.3.0 from /usr/local/lib/python2.7/dist-packages
      pbr>=0.11: 1.8.0 from /usr/local/lib/python2.7/dist-packages
      six>=1.7: 1.9.0 from /usr/local/lib/python2.7/dist-packages
      funcsigs: 0.4 from /usr/local/lib/python2.7/dist-packages/funcsigs-0.4-py2.7.egg
    appdirs>=1.1.0: 1.4.0 from /usr/local/lib/python2.7/dist-packages
    gpsoauth==0.0.3: 0.0.3 from /usr/local/lib/python2.7/dist-packages
      pycrypto: 2.6.1 from /usr/local/lib/python2.7/dist-packages
      requests: 2.7.0 from /usr/local/lib/python2.7/dist-packages
GStreamer: from /usr/lib/python2.7/dist-packages/gst-0.10/gst
  Detailed information: 
    Python wrapper: gst-python
    Relevant elements:
      Not found:

mopidy config

cache_dir = $XDG_CACHE_DIR/mopidy
config_dir = $XDG_CONFIG_DIR/mopidy
data_dir = $XDG_DATA_DIR/mopidy
max_tracklist_length = 10000

color = true
console_format = %(levelname)-8s %(message)s
debug_format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s\n  %(message)s
debug_file = mopidy.log
config_file =

mixer = software
mixer_volume = 
output = autoaudiosink

scheme = 
hostname = 
port = 
username = 
password = 

enabled = true
username = cypresstwist
password = ********
deviceid = 334340280EA00B10

enabled = true
hostname =
port = 6600
password = 
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist = 

enabled = true
hostname =
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname

enabled = true
protocols = 
metadata_blacklist = 
timeout = 5000

enabled = true
playlists_dir =

enabled = true

enabled = true
media_dirs = 
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

enabled = true
library = json
media_dir = $XDG_MUSIC_DIR
data_dir = $XDG_DATA_DIR/mopidy/local
scan_timeout = 1000
scan_flush_threshold = 100
scan_follow_symlinks = false
excluded_file_extensions = 

I’m guessing that you have a too old GStreamer version, as your playbin2 element doesn’t know about the source-setup signal.

More importantly, your Ubuntu version hasn’t received any security updates for the last 20 months. The only proper way of fixing this is to upgrade your Ubuntu system. Or even better, reinstall it, as it is probably quite leaky and compromised.

Good to know. I’ll try and compile a more recent GStreamer.
As for my Ubuntu 11.04 version, I’m stuck with it on this laptop as it’s the decentest Linux that can run on it without bringing it to a complete halt. It’s an old Dell Inspiro Mini with onboard Intel graphics and 2GB of RAM. I tried installing other distros on it but Unity, GNOME 3 and KDE 4 are resource-hungry and the laptop becomes unusable. GTK 2.x runs well on it. It’s either that or Fluxbox.

Have you tried XFCE? It runs absolutely fine on my old netbook.

XFCE, GNOME - it doesn’t matter that much. It’s all about GTK. GTK 2.x runs fine. GTK 3.x apps grind my system to the point that it becomes hell to use this machine.