[Solved] Gmusic, mopidy as service, pysan1 error


#1

Hello

First post here, and I’ll start with thanking the devs for letting me turn my RBPi 3 into a music player.

I’m running Raspbian (Stretch), and I’ve installed mopidy and gmusic. Everything is working perfectly as I run mopidy as a user, but Gmusic extension fails to load when running mopidy as a service.

Here is the log:

2018-07-04 20:52:22,110 INFO [564:MainThread] mopidy.main: Starting Mopidy 2.1.0
2018-07-04 20:52:22,455 INFO [564:MainThread] mopidy.config: Loading config from builtin defaults
2018-07-04 20:52:22,468 INFO [564:MainThread] mopidy.config: Loading config from /etc/mopidy/mopidy.conf
2018-07-04 20:52:22,476 INFO [564:MainThread] mopidy.config: Loading config from command line options
2018-07-04 20:52:22,928 INFO [564:MainThread] mopidy.ext: Disabled extension gmusic: (pyasn1 0.3.4 (/usr/local/lib/python2.7/dist-packages), Requirement.parse(‘pyasn1<0.5.0,>=0.4.1’), set([‘pyasn1-modules’]))
2018-07-04 20:52:23,231 INFO [564:MainThread] mopidy.main: Enabled extensions: mpd, http, stream, m3u, softwaremixer, file, local
2018-07-04 20:52:23,233 INFO [564:MainThread] mopidy.main: Disabled extensions: gmusic
2018-07-04 20:52:24,470 INFO [564:MainThread] mopidy.commands: Starting Mopidy mixer: SoftwareMixer
2018-07-04 20:52:24,477 INFO [564:MainThread] mopidy.commands: Mixer volume set to 10
2018-07-04 20:52:24,479 INFO [564:MainThread] mopidy.commands: Starting Mopidy audio
2018-07-04 20:52:24,485 INFO [564:MainThread] mopidy.commands: Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend, LocalBackend
2018-07-04 20:52:24,548 INFO [564:MainThread] mopidy.local.library: Loaded 0 local tracks using json
2018-07-04 20:52:24,562 INFO [564:MainThread] mopidy.commands: Starting Mopidy core
2018-07-04 20:52:24,613 INFO [564:Audio-2] mopidy.audio.actor: Audio output set to “autoaudiosink”
2018-07-04 20:52:24,617 INFO [564:MainThread] mopidy.commands: Starting Mopidy frontends: MpdFrontend, HttpFrontend
2018-07-04 20:52:24,628 INFO [564:MainThread] mopidy.mpd.actor: MPD server running at [::ffff:192.168.1.5]:6600
2018-07-04 20:52:24,638 INFO [564:HttpFrontend-10] mopidy.http.actor: HTTP server running at [::ffff:192.168.1.5]:6680
2018-07-04 20:52:24,639 INFO [564:MainThread] mopidy.commands: Starting GLib mainloop

I have seen something similar in another thread somewhere now cannot find it. Am I right in thinking that something to do with pysan1 mustn’t be available to the service, and maybe wasn’t installed correctly? I have tried to retrace my steps and install everything with sudo, but I can’t seem to be able to shake the error. Next course of action is reinstall everything from scratch unless someone can point me in the right direction?

Thanks for reading.


#2

Normally you would run sudo mopidyctl deps to show all the versions and locations. Perhaps you could try comparing that with mopidy deps to see the difference. https://docs.mopidy.com/en/latest/troubleshooting/


#3

Solution here I think; https://github.com/mopidy/mopidy-gmusic/issues/180


#4

Thank you both for your quick reply.

I think I must be missing something very basic.
@Steve_Lambert thank you, that’s the thread I saw yesterday and tried to replicate the fix, without luck. See below.

After doing

sudo easy_install pyasn1==0.4.3
Searching for pyasn1==0.4.3
Reading https://pypi.python.org/simple/pyasn1/
Downloading https://files.pythonhosted.org/packages/15/04/ea58585fb6bcfaa1a0f6e453cf9fdce2f5943802d745dd355c630bfe2120/pyasn1-0.4.3-py2.7.egg#sha256=3651774ca1c9726307560792877db747ba5e8a844ea1a41feb7670b319800ab3
Best match: pyasn1 0.4.3
Processing pyasn1-0.4.3-py2.7.egg
Moving pyasn1-0.4.3-py2.7.egg to /usr/local/lib/python2.7/dist-packages
Removing pyasn1 0.4.1 from easy-install.pth file
Adding pyasn1 0.4.3 to easy-install.pth file
Installed /usr/local/lib/python2.7/dist-packages/pyasn1-0.4.3-py2.7.egg
Processing dependencies for pyasn1==0.4.3
Finished processing dependencies for pyasn1==0.4.3

When running

sudo mopidyctl deps

I still get:

pyasn1-modules>=0.0.5: 0.2.2 from /usr/local/lib/python2.7/dist-packages
pyasn1<0.5.0,>=0.4.1: not found
pyasn1>=0.1.7: 0.3.4 from /usr/local/lib/python2.7/dist-packages

Please help a newb, thanks in advance.


#5

Hi

sudo pip install pyasn1==0.4.3

fixed the problem. Thank you for your help!