SoundCloud gets lost every time you turn off raspberry.


#1

I have this as a problem for me, I add token saved right SoundCloud restart, it appears I use it all right, when for some reason I need to turn off the raspeberry pi 3 , the system returns without SoundCloud, I wonder if I do something wrong or system works anyway.


#2

Where did you add the token? In the settings.ini or in the webinterface?


#3

I have the same issue. Restarting Mopidy after reboot solves it for me. My guess is the Souncloud plugin tries to connect to Soundcloud to early, when netwerk connectivity is not OK yet (WIFI). I’m going to try to put a delay in startup of the Mopidy service.


#4

This is what the wait for network setting is for. Are you using it?


#5

I’m running Mopudy on Ubuntu, didn’t notice this topuc was under MusicBox. Is the wait for network a Mopidy setting, or a Linux daemon setting?


#6

It’s part of the pimusicbox scripts. I think there is a setting in network manager or whatever Ubuntu uses that does wait for the network to come up. But anyway, not having a network connection is not the issue here so maybe start a new topic.