Sound distortion on Mopidy and HifiBerry DAC+


I have instaled mopidy (latest) and HifiBerry DAC+ with MusicBox_WebClient extension
Works fine but when i put slider volume above half there is a distortion on DAC output.
I have set digital volume in AlsaMixer v1.0.28 to 25 and sound in not loud but still distorted.
All changes i made to volume is made in AlsaMixer with command:
sudo -H -u mopidy alsamixer -D equal and then i select soundcard: snd_rpi_hifiberry_dacplus

My question is which volume does MusicBox_WebClient change? how to limit this volume to 50% ?

Have you looked at Settings for piMusicBox 0.6 and HifiBerry Dac +? ?

Yes i do, but distortion is still there.

Im not using MusicBox, but have installed Mopidy manually, so i dont have settings.ini. I have also succsesfuly install equalizer, which is the reason to go manually install from scratch.

These are my settings in mopidy.conf:

output = alsasink device=plug:plugequal
mixer = software
mixer_volume = 20

enabled = true
card = 0
control = Digital

Changing: amixer sset Digital 160 to lower or higher value, also distorsion comes louder or quieter. So distorsion comes before amixer. I think it can be Mopidy software mixer? is it possible to limit software mixer not to 100% but 60%

With the mixer = software configuration you’ve given above, changes to Mopidy’s volume (via musicbox-webclient or any other Mopidy client) will change the software volume i.e. before the output pipeline. You would need to specify mixer = alsamixer to change this behaviour.

I don’t think it’s possible to arbitrarily limit Mopidy’s software volume, you just need to be mindful when adjusting the volume in your client.

But I also don’t think it makes sense for that to introduce distortion, providing you have set hardware volume appropriately using amixer. And of course this runs contrary to the experiences of others in the previous thread on the exact same subject that I mentioned above. The only thing different between you and them is you are using equalizer. Do you still get distortion when you remove the equalizer from your output pipeline?

I have tested configuration without EQ, and it is working without distortion. So i have to ask for solution on other forum.
Thanks for advise.