[SOLVED] Help! There's an exception in my M3U backend


I’m rather new to all this but have managed to get Mopidy working smoothly on a Raspberry Pi following the excellent instructions on the Mopidy website. Everything with the exception of the playlist backend. I get this error:

ERROR M3UBackend backend caused an exception.
Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/mopidy/core/playlists.py”, line 18, in _backend_error_handling
File “/usr/lib/python2.7/dist-packages/mopidy/core/playlists.py”, line 66, in as_list
playlists = future.get()
File “/usr/lib/python2.7/dist-packages/pykka/threading.py”, line 52, in get
File “/usr/lib/python2.7/dist-packages/pykka/compat.py”, line 12, in reraise
exec(‘raise tp, value, tb’)
File “/usr/lib/python2.7/dist-packages/pykka/actor.py”, line 201, in _actor_loop
response = self._handle_receive(message)
File “/usr/lib/python2.7/dist-packages/pykka/actor.py”, line 295, in _handle_receive
return callee(*message[‘args’], **message[‘kwargs’])
File “/usr/lib/python2.7/dist-packages/mopidy/m3u/playlists.py”, line 75, in as_list
File “/usr/lib/python2.7/dist-packages/mopidy/m3u/translator.py”, line 76, in path_to_ref
File “/usr/lib/python2.7/dist-packages/mopidy/models/init.py”, line 77, in playlist
return cls(**kwargs)
File “/usr/lib/python2.7/dist-packages/mopidy/models/immutable.py”, line 158, in call
*args, **kwargs)
File “/usr/lib/python2.7/dist-packages/mopidy/models/immutable.py”, line 34, in init
self._set_field(key, value)
File “/usr/lib/python2.7/dist-packages/mopidy/models/immutable.py”, line 186, in _set_field
object.setattr(self, name, value)
File “/usr/lib/python2.7/dist-packages/mopidy/models/fields.py”, line 50, in set
value = self.validate(value)
File “/usr/lib/python2.7/dist-packages/mopidy/models/fields.py”, line 101, in validate
return compat.intern(value)
TypeError: can’t intern subclass of string

I did try to point the config to a folder I’ve created but when the error came up I reset the config to default.

Other backends I’m running (and without issue are) all the other standard Mopidy ones (podcast, MPD, etc). As well as:

Spotify tunigo

Any help would be much appreciated because at present I am unable to save any playlists and the red text annoys me greatly.

Ta v much!


You get this error when you set m3u/playlists_dir to any string?

This sounds like a bug in Mopidy. Can you report it at https://github.com/mopidy/mopidy/issues/new ?

Thanks for replying Jodal.

I tried to set a custom location (mkdir etc.) on first install/config, like this:

enabled = true
playlists_dir = home/pi/playlists
base_dir = /home/pi
default_encoding = latin-1
default_extension = .m3u8

had the error, and then reverted to default, like so:

enabled = true
playlists_dir =
base_dir = $XDG_MUSIC_DIR
default_encoding = latin-1
default_extension = .m3u8

and also tried this:

enabled = true
playlists_dir =
base_dir =
default_encoding = latin-1
default_extension = .m3u8

But I get the same error regardless.

If you still think its a bug and not just user error I’d be happy to raise as an issue.




This can finally be solved now by upgrading Mopidy-GMusic to v2.0.0:

pip install --upgrade Mopidy-GMusic