Slow volume response with raspberri pi2 & hifiberry DAC+

I’m using a raspberry pi 2 with stock raspbian os. I"ve followed the guide of hifiberry for the DAC+ using the dtoverlay paramater in the config.txt file.


I needed to apply Appendix A from the mopidy installation section to get the sound working, otherwise i would get gstreamer errors.

But the problem at hand is very slow volume response. The track changes are immediate, but the volume controls have a delay of several seconds. First i was thinking in the direction of buffering, but because track changes are done immediate, i don’t think buffering is the issue here. Somebody knows what could be the problem. Either frontend i use show the same delay. If i use alsamixer command line, the changes are immediate. Is there a possibility to let mopidy change the alsamixer volume control?

I’ve installed following extensions:


Below i include my mopidy config:

enabled = true
hostname = ::

enabled = true
hostname = ::

config_file = /etc/mopidy/logging.conf
debug_file = /var/log/mopidy/mopidy-debug.log

playlists_dir = /var/lib/mopidy/playlists

enabled = false
data_dir = /var/lib/mopidy/local
media_dir = /var/lib/mopidy/media

mixer = software
mixer_volume = 50
output = alsasink

card = 0
control = PCM

enabled = true
username = <spotify_user>
password = <spotify_password>
bitrate = 320

Sounds a bit like this, a fix is in the works.

Indeed, looks like the same bug, I searched for duplicates, but that one didn’t pop-up

did you try to set

mixer = alsamixer

That works perfectly, thanks for the tip!