Mopidy Discourse

Problem with Mopidy-SoundCloud : Invalid "auth_token"

I get an error when i’m running mopidy with soundcloud extension. I’m using mopidy on a debian virtual machine. I followed the instructions mentioned on the github page (here : “GitHub - mopidy/mopidy-soundcloud: Mopidy extension for playing music from SoundCloud”), with configuring the “mopidy.conf” located on “/home/user/.config/mopidy”, and I added my token and “explore_songs”. Here is my file configuration if needed :

# For further information about options in this file see:
#   https://docs.mopidy.com/
#
# The initial commented out values reflect the defaults as of:
#   Mopidy 3.2.0
#   Mopidy-File 3.2.0
#   Mopidy-HTTP 3.2.0
#   Mopidy-M3U 3.2.0
#   Mopidy-SoftwareMixer 3.2.0
#   Mopidy-Stream 3.2.0
#   Mopidy-YouTube 3.4
#
# Available options and defaults might have changed since then,
# run `mopidy config` to see the current effective config and
# `mopidy --version` to check the current version.

[core]
#cache_dir = $XDG_CACHE_DIR/mopidy
#config_dir = $XDG_CONFIG_DIR/mopidy
#data_dir = $XDG_DATA_DIR/mopidy
#max_tracklist_length = 10000
#restore_state = false

[logging]
#verbosity = 0
#format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s\n  %(message)s
#color = true
#config_file =

[audio]
#mixer = software
#mixer_volume = 
#output = autoaudiosink
#buffer_time = 

[proxy]
#scheme = 
#hostname = 
#port = 
#username = 
#password = 

[youtube]
#enabled = true
#allow_cache = 
#youtube_api_key = 
#search_results = 15
#playlist_max_videos = 20
#api_enabled = false
#channel_id = 
#musicapi_enabled = false
#musicapi_cookie = 
#autoplay_enabled = false
#strict_autoplay = false
#max_autoplay_length = 600
#max_degrees_of_separation = 3

[file]
#enabled = true
#media_dirs = 
#  $XDG_MUSIC_DIR|Music
#  ~/|Home
#excluded_file_extensions = 
#  .directory
#  .html
#  .jpeg
#  .jpg
#  .log
#  .nfo
#  .pdf
#  .png
#  .txt
#  .zip
#show_dotfiles = false
#follow_symlinks = false
#metadata_timeout = 1000

[http]
#enabled = true
#hostname = 127.0.0.1
#port = 6680
#zeroconf = Mopidy HTTP server on $hostname
#allowed_origins = 
#csrf_protection = true
#default_app = mopidy

[m3u]
#enabled = true
#base_dir = $XDG_MUSIC_DIR
#default_encoding = latin-1
#default_extension = .m3u8
#playlists_dir =

[softwaremixer]
#enabled = true

[stream]
#enabled = true
#protocols = 
#  http
#  https
#  mms
#  rtmp
#  rtmps
#  rtsp
#metadata_blacklist = 
#timeout = 5000

[soundcloud]
auth_token = XXXXXXXXXXXXXXXXXXX
explore_songs = 25

Where “XXXXXXX…” is my token for SoundCloud I activated here :

But when I’m running it in a terminal the extension doesn’t work, and tell me this message :

" "

I purged the packet, uninstalling and reinstalling, the error still occurs. Any idea why i get this message ?

Thank you for helping

You didn’t add the error message. If you can do that it would be helpful.

Hi, I also have this issue. The error message I see is simply:

Oct 11 12:28:18 jupiter.local mopidy[1720238]: ERROR    2021-10-11 12:28:18,096 [1720238:SoundCloudBackend-7] mopidy_soundcloud.soundcloud
Oct 11 12:28:18 jupiter.local mopidy[1720238]:   Invalid "auth_token" used for SoundCloud authentication!

I tried producing a new token using this page, but now I get a “signin_denied” message from soundcloud when following the flow:

I was able to undo the signin_denied error by revoking Mopidy as a “connected application” in soundcloud (here), which then allowed me to go through the OAuth flow again - successfully generating a new token - but even after successfully generating this new auth token, the auth error in mopidy persists.

I’m using the current version of mopidy-soundcloud which is in the AUR. I also tried sudo python3 -m pip install Mopidy-SoundCloud, but that version also suffers from the same issue.

Hi, I also have this issue. The error message I see is simply:

Oct 11 12:28:18 jupiter.local mopidy[1720238]: ERROR    2021-10-11 12:28:18,096 [1720238:SoundCloudBackend-7] mopidy_soundcloud.soundcloud
Oct 11 12:28:18 jupiter.local mopidy[1720238]:   Invalid "auth_token" used for SoundCloud authentication!

I tried producing a new token using the auth flow on the extension page on the mopidy website, but now I get a “signin_denied” message from soundcloud when following the flow:

I was able to undo the signin_denied error by revoking Mopidy as a “connected application” in Soundcloud’s settings page, which then allowed me to go through the OAuth flow again - successfully generating a new token - but even after successfully generating this new auth token, the auth error in mopidy persists.

I’m using the current version of mopidy-soundcloud which is in the AUR. I also tried sudo python3 -m pip install Mopidy-SoundCloud, but that version also suffers from the same issue.

I tried using mitmproxy to look at the request & response to the soundcloud API, but it seems like SSL certificate pinning has been enabled, so I can’t snoop to see if the response is actually returning with a failure.

The bad auth token issues are probably due to API Changes · Issue #123 · mopidy/mopidy-soundcloud · GitHub

I don’t know what they are up to at soundcloud. It’s weird they’ve started working on their systems again (after a long period of nothing) but are still not accepting new API access registrations. This has been their biggest issue by a long way for many years. It’s the only thing people are asking for but instead they roll out this stuff and a load of uninteresting blog posts. I’m not interested in touching soundcloud until they address this elephant. But anyone else is very welcome to take a look.

1 Like

Yes, I was going to do it but the subject has been locked before I do the edit, sorry.
But yeah, my error is the same as johnhamelink posted :

ERROR    2021-10-11 20:34:35,463 [30628:SoundCloudBackend-6] mopidy_soundcloud.soundcloud
  Invalid "auth_token" used for SoundCloud authentication! 

I’ve read why this issue is happening, because of the API. Hope SC allows API’s auth again.

To be clear, the current issue can be fixed if someone implements the new auth restrictions. I’m just saying I’m not interested in doing that myself at this point in time.