Can use mopidy-soundcloud when starting as local user but not through systemctl

I’ve added the following to both my local config and to /etc/config/mopidy/mopidy.conf:

auth_token = <my token>

When I start mopidy as a local user by just running mopidy on the command line, it works fine.

However, when I run it as a systemd service with sudo systemctl start mopidy.service, the soundcloud backend is not started and the log shows the following message:

2020-05-31 14:42:07,101 INFO [21585:MainThread] mopidy.main: Disabled extensions: spotify, soundcloud
2020-05-31 14:42:07,101 WARNING [21585:MainThread] mopidy.main: Found soundcloud configuration errors. The extension has been automatically disabled:
2020-05-31 14:42:07,101 WARNING [21585:MainThread] mopidy.main: soundcloud/auth_token must be set.

I’m not sure what’s wrong here since the token is set identically in both the global and the local config files.

Does anyone have an idea how to fix this?

Use sudo mopidyctl config to show what the service sees as the config. This is documented at