No sound on raspberry pi bookworm

Hi all

I have installed the lasest version of Pi OS onto a Raspberry Pi 4. I wont Mopidy to output via the headphone jack.

I have tried to folllow the instructions at:

The test

aplay /usr/share/sounds/alsa/Front_Center.wav

is correctly playing sound out of the headphone jack into the speaker.

However Mopidy it’s self outputs no sound. I think this is possbly becuase Rpi OS not uses pipewire be default and not alsa.

Is there a newer of the instrustions available with the solution to this please?

I think you were meaning to say that Rpi OS uses pipewire by default. And for anyone curious, their bookworm lite image still uses ALSA.

Got a pipewire setup, try Add documentation for running as a user service · Issue #1974 · mopidy/mopidy · GitHub


I’ve just tried this and no dice.

And you have pipewire-pulse installed?

I do indeed.

pipewire-pulse is already the newest version (0.3.65-3+rpt6+deb12u1).

Just ran into this issue. The problem is that the install script modifies /boot/config.txt, but in bookworm, the file that needs to be modified is /boot/firmware/config.txt.
You can fix this by modifying the install script before running it:

just change the path to the config.txt file. Also, @kingosticks or any other maintainer, I put up a PR to fix this.