No audio outputs listed in IRIS

Hello, I am trying to play spotify songs through headphones/ speakers plugged into a linux computer. When I click play on a song it looks like it is playing, but no sound is coming through the headphones. The audio button on bottom (next to shuffle and volume control) also shows no outputs. Here’s my config file when typing sudo mopidyctl config:

Running “/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf config” as user mopidy
[core]
cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy
max_tracklist_length = 10000
restore_state = false

[logging]
verbosity = 0
format = %(levelname)-8s [%(threadName)s] %(name)s %(message)s
color = false
config_file =

[audio]
mixer = none
mixer_volume =
output = autoaudiosink
buffer_time =

[proxy]
scheme =
hostname =
port =
username =
password =

[spotify]
enabled = true
username = myActualUsername
password = ********
client_id = clientID
client_secret = ********
bitrate = 160
volume_normalization = true
private_session = false
timeout = 10
allow_cache = true
allow_network = true
allow_playlists = true
search_album_count = 20
search_artist_count = 10
search_track_count = 50
toplist_countries =

[raspberry-gpio]
enabled = false ; Extension disabled by user config.

[radionet]
enabled = true
language = pl
min_bitrate = 96

[iris]
enabled = true
country = NZ
locale = en_NZ
spotify_authorization_url = https://jamesbarnsley.co.nz/iris/auth_spotify.php
lastfm_authorization_url = https://jamesbarnsley.co.nz/iris/auth_lastfm.php
genius_authorization_url = https://jamesbarnsley.co.nz/iris/auth_genius.php
data_dir = $XDG_DATA_DIR/iris

[gmusic]
enabled = true
refresh_token = ********
bitrate = 160
deviceid =
all_access = false
refresh_library = 1440
refresh_playlists = 60
radio_stations_in_browse = true
radio_stations_as_playlists = false
radio_stations_count =
radio_tracks_count = 25
top_tracks_count = 20

[file]
enabled = true
media_dirs =
$XDG_MUSIC_DIR|Music
~/|Home
excluded_file_extensions =
.directory
.html
.jpeg
.jpg
.log
.nfo
.pdf
.png
.txt
.zip
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

[http]
enabled = true
hostname = 0.0.0.0
port = 6680
zeroconf = Mopidy HTTP server on $hostname
allowed_origins =
csrf_protection = true
default_app = mopidy

[m3u]
enabled = true
base_dir =
default_encoding = latin-1
default_extension = .m3u8
playlists_dir =

[softwaremixer]
enabled = true

[stream]
enabled = true
protocols =
http
https
mms
rtmp
rtmps
rtsp
metadata_blacklist =
timeout = 5000

[mpd]
enabled = true
hostname = 0.0.0.0
port = 6600
password =
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist =
listall
listallinfo
default_playlist_scheme = m3u

So, this is a raspberry pi?

There are other posts on here with raspberry pi audio isuees resolved, what things have you tried?

Hello, thanks for the response. You are correct, it is a raspberry pi. I have viewed some of the other posts on here about audio output-

I tried creating an asound.conf file in my /etc folder like in this issue: No audio output with Mopidy + Mopidy Iris + HiFiBerry DAC+ Pro [solved] (I’m not using a HiFiBerry, just the pi’s audio jack) Is there further configuration I need to do on this?

I was also not able to get sound at any point, unlike this issue:

I’ve also tried changing-

[audio]
mixer = none
output = alsasink

to [audio]
mixer = none
output = autoaudiosink

I’ve also tried typing gst-launch-1.0 audiotestsrc ! audioresample ! autoaudiosink and get the following, but with no sound:

Setting pipeline to PAUSED …
Pipeline is PREROLLING …
Redistribute latency…
Pipeline is PREROLLED …
Setting pipeline to PLAYING …
New clock: GstAudioSinkClock
It may be worth noting that I have one “blacklisted entry” when checking my plugins with gst-inspect-1.0? Very new to linux in general so not sure…

Keep output = alsasink like our documentation recommends. Is this Raspbian Desktop or Lite? Are you using a screen plugged into the HDMI output? Are you running Mopidy as a service? Is the 3.5 audio jack enabled (via raspi-config)?

If you look at the output of aplay -l you should see something like the following showing what card and device numbers to use for your audio jack (called “Headphones”):

pi@testpi:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
  Subdevices: 7/8
  Subdevice #0: subdevice #0
  blah blah blah ...

In my case it’s card 0 and device 0 (AKA hw:0,0) so to explicitly use that for output you can do:

gst-launch-1.0 audiotestsrc ! audioresample ! alsasink device=hw:0,0

To do the same thing for Mopidy use:

[audio]
output = alsasink device=hw:0,0

Then restart Mopidy.

My device was 1,0 but adding device=hw:0,0 solved my problem.

To answer your questions though, this is Raspbian Desktop. I’m plugged into a screen through HDMI, and I’m running Mopidy as a service. The 3.5mm jack is indeed enabled through raspi-config.

Thanks!

So, presumably if you have a HDMI cable plugged in (I don’t) then you have two devices and you need to ensure you select the right one. I think (never looked) that when you use sudo raspi-config to select the 3.5 audio output as the default it creates a file in /home/pi/.asoundrc which means that default setting is only visible to the pi user and the rest of the system (including any services running as other users - such as Mopidy - are unaffected). I don’t know why raspi-config does this. But I guess it means another alternate fix might be to move /home/pi/.asoundrc to /etc/asound.conf. Personally I don’t think having a /home/pi/.asoundrc file is helpful but maybe it’s to support what desktop programs running as the pi user expect.

My device was 1,0 but adding device=hw:0,0 solved my problem.

I don’t understand this statement (surely hw:1,0 would be what you wanted…?) but if you’ve got it working now then that’s great.

Typo, you are correct, it was adding hw:1,0 that fixed my problem.

1 Like

Oh good thanks for confirming. I think we need something in the documentation about this.

For further clarification:
-Yes, I am using an HDMI display.
-I did not see an asoundrc file in my /home/pi directory after doing sudo raspi-config to set 3.5mm, but it could have been hidden or under the root user?

Either way, I did sudo cp .asoundrc /etc/asound.conf to create the asound.conf file and then added output = alsasink device=hw:1,0 under audio.

Thanks again for the help.

Yeh, it would have been hidden. Files starting with a period are hidden by default.