Musicbox in standby?

Running Musicbox 0.7.0RC on Rasberry Pi 3
Enabled Airplay in settings
Save and reboot device
Login with user root

I open Spotify (Premium) on my iOS device and airplay to the musicbox. Works great, but after a while the musicbox seems to go in standby mode or something. If i try to airplay to device i recieve the error: no connection possible with Musicbox. Connected the Pi to my tv with HDMI and also after a while i get a blank screen. I need to reboot and login again to get Airplay to work again. But after a while the screen turn blank again and airplay doesnt work.

How can i get the Pi to stay ‘active’ and i can airplay to it at every moment without rebooting and login in every time?


There is no standby mode with a raspberry pi so I don’t think it’s that. Is the normal web interface still accessible when this happens? How long does it take for this to occur?

Hi kingosticks,

Musicbox.local is still accessible and i can play music. Airplay with my iOS device isnt working. When i check the tv HDMI the screen is empty. I dont really know how long it takes before the airplay isnt working anymore. I tried it from time to time.

Update: i tried some things out with airplay from spotify and youtube and within 5 minutes i cant airplay to the musicbox anymore.

Formatted the SD and wrote a new Musicbox 0.7.0 RC4 on it. Enabled settings for Airplay. Open Spotify and stream music through airplay to the Raspberry, works great. Tried it again after several minutes later and now the airplay doesnt connect to Musicbox anymore.

No one with the same problem or has an answer for me?

It’s possible related to a bug in the configuration. Can you try both of the following:

  • Increase the number of control ports available for use in case your client is attempting to open another connection whilst the original connection is still active:
sed -i 's/udp_port_range = 3/udp_port_range = 100/' /etc/shairport-sync.conf
  • Disable the firewall (reported to be an issue depending on your particular client):
iptables -P INPUT ACCEPT
iptables -F
iptables -X

Hi king,

I did the things you said, but still after ±5 minutes i cant airplay anymore. I insert all the lines you said and Entered after every line.

Can you check if the airplay service is still running after it becomes unresponsive? Run

service shairport-sync status

[ok] shairport-sync is running