Mopidy Discourse

Mopidy with Pummeluff Extension

Excuse the n00b.

I’ve found my stash of pi b+ 1.2’s and wanted to have a go at making a rfid music player, I came across mopidy-pummeluff and have tried following the instructions on stretch and buster both times failing.

mopidy installs fine on buster from apt, on stretch tells me no Opengpg data found, so can only install using either python3 -m pip install or pip install mopidy,

when I install using either pip I seem unable to to get mopidy running as a service, no mopidy.service found

if I install on buster with apt then install the extensions with pip, it crashes saying something about extension %% no name

as a starting point… has anyone used this extension? which distro did you use, and which way did you install it.

I apologise if it’s me being thick. but willing to try to learn, my knowledge of linux is limited but getting better and better.

AttributeError: ‘Extension’ object has no attribute ‘version’

was one error when trying to install via pip.

I’m just refreshing back to a buster lite sd card, will make note of errors more in detail so I can be more specific

Stretch is too much old, no new project should be using Debian Stretch.

PyPi (pip) provides Python packages only so you won’t find the extra files required for a system service there. Install Mopidy from apt.mopidy.com as per our documentation. Install the extension using

sudo python3 -m pip install mopidy-pummeluff

The instructions on the mopidy-pummeluff are not helpful for a Python 3 install (which is the only version Mopidy supports),

followed instructions at mopidy.com

followed instructions above

result:

Traceback (most recent call last):
File “/usr/bin/mopidy”, line 11, in
load_entry_point(‘Mopidy==3.2.0’, ‘console_scripts’, ‘mopidy’)()
File “/usr/lib/python3/dist-packages/mopidy/main.py”, line 46, in main
extensions_data = ext.load_extensions()
File “/usr/lib/python3/dist-packages/mopidy/ext.py”, line 259, in load_extensions
“Loaded extension: %s %s”, extension.dist_name, extension.version
AttributeError: ‘Extension’ object has no attribute ‘version’

PRETTY_NAME=“Raspbian GNU/Linux 10 (buster)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“10”
VERSION=“10 (buster)”
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian

You’ve probably got a non-Mopidy 3 extension installed i.e. an extension that only works in old (unsupported) Mopidy 2. We fixed this back in July but there’s no released including it. Either way, real fix is to remove the bad extension.

mopidy-pummeluff is the only extension I have installed so far following the instructions in kingosticks/mopidy-pummeluff to build from source.

obvs doing something wrong somewhere. lol

How are you running Mopidy? As a service or in your terminal? Provide your full log showing the traceback occurring. Also provide the full output of deps for the way you are running Mopidy i.e if running as a service then use sudo mopidyctl deps.

I ran into the same issue, and submitted a PR to fix it. fix: Mopidy plugin must expose version number by alepee · Pull Request #26 · confirm/mopidy-pummeluff · GitHub

Mopidy-Pummeluff does not expose a version as required by Mopidy.

Since the PR has not been merge yet, you can alter manually the __init__.py file accordingly. It should be located under /usr/local/lib/python3.9/dist-packages/mopidy_pummeluff/ (make sure the python3.9 is the correct version on your system)