Mopidy version 3 not following symlinks

installed latest version

 mopidy --version
Mopidy 3.0.1

working Ok for local folders but unable to scan symlinks even with this option set to TRUE. Here the file section from .config/mopidy/mopidy.conf

[file]
   enabled = true
   media_dirs =
   $XDG_MUSIC_DIR|Music
   ~/|Home
  #excluded_file_extensions =
  #  .directory
  #  .html
  #  .jpeg
  #  .jpg
  #  .log
  #  .nfo
  #  .pdf
  #  .png
  #  .zip
  #show_dotfiles = false
  follow_symlinks = true
  #metadata_timeout = 1000

starting mopidy as user

mopidy

WARNING  2020-02-24 12:23:21,985 [10007:MainThread] mopidy_local.commands
  Encountered 1 errors while finding files in file:///home/jose/Music
WARNING  2020-02-24 12:23:21,985 [10007:MainThread] mopidy_local.commands
  Error for file:///home/jose/Music/PNY: ('Not following symlinks.', None)

what is very strange, in mopidy config seems to have blocked the scan_follow_symlinks true and false at same time

mopidy config | grep follow
follow_symlinks = true
scan_follow_symlinks = false

added to config just in case

WARNING  2020-02-24 12:07:19,660 [8647:MainThread] mopidy.__main__
    file/scan_follow_symlinks unknown config key.

mopidy deps

 mopidy deps
Executable: /usr/local/bin/mopidy
Platform: Linux-5.3.0-40-generic-x86_64-with-Ubuntu-19.10-eoan
Python: CPython 3.7.5 from /usr/lib/python3.7
Mopidy: 3.0.1 from /usr/local/lib/python3.7/dist-packages
  requests: 2.21.0 from /usr/lib/python3/dist-packages
  Pykka: 2.0.2 from /usr/local/lib/python3.7/dist-packages
  tornado: 6.0.3 from /usr/local/lib/python3.7/dist-packages
  setuptools: 41.1.0 from /usr/lib/python3/dist-packages
Mopidy-Local: 3.1.1 from /usr/lib/python3/dist-packages
Mopidy-MPD: 3.0.0 from /usr/local/lib/python3.7/dist-packages
  Pykka: 2.0.2 from /usr/local/lib/python3.7/dist-packages
  Mopidy: 3.0.1 from /usr/local/lib/python3.7/dist-packages
  setuptools: 41.1.0 from /usr/lib/python3/dist-packages
Mopidy-Spotify: 4.0.1 from /usr/lib/python3/dist-packages
GStreamer: 1.16.1.0 from /usr/lib/python3/dist-packages/gi
  Detailed information:
    Python wrapper: python-gi 3.34.0
    Relevant elements:
      Found:
 uridecodebin
        souphttpsrc
        appsrc
        alsasink
        osssink
        oss4sink
        pulsesink
        id3demux
        id3v2mux
        lamemp3enc
        mpegaudioparse
        mpg123audiodec
        vorbisdec
        vorbisenc
        vorbisparse
        oggdemux
        oggmux
        oggparse
        flacdec
        flacparse
        shout2send
Not found:
        flump3dec
        mad

Mopidy-File and Mopidy-Local are two different backends with different behaviour and different config options. There is no problem with configuring each of them to have differnent behaviour with regards to following symlinks.

It sounds like you are trying to use Mopidy-Local, are you? If so, the [file] config section is not relevent. Instead you need to set scan_follow_symlinks = true under the local config section.

did not have a [local] section, so I created it and now is working.
thanks

Excellent news.

We advise only adding things to your config file where the config value you want differs from Mopidy’s default. So, in your case, it might contain just two lines:

[local]
scan_follow_symlinks = true
1 Like