Mopidy Discourse

Mopidy unable to connect to icecast2

this used to work just fine on my device, however i tried to change encoding from lamemp3enc to ogg and it stopped working, i have scince tried back with lamemp3enc, reinstalling both mopidy and icecast but nothing seems to work
mopidy.conf
output = audioresample ! audioconvert ! vorbisenc ! oggmux ! shout2send async=false mount=mopidy ip=127.0.0.1 port=11000 password=stuff
icecast.xml is pretty much default

<hostname>127.0.0.1</hostname>
<listen-socket>
        <port>11000</port>
        <!-- <bind-address>127.0.0.1</bind-address> -->
        <!-- <shoutcast-mount>/stream</shoutcast-mount> -->
    </listen-socket>

<mount>
  <mount-name>/mopidy</mount-name>
  <fallback-mount>/silence.ogg</fallback-mount>
  <fallback-override>1</fallback-override>
</mount>

mopidy will show this error message

ERROR    2021-03-17 20:05:34,118 [12558:MainThread] mopidy.audio.gst
  GStreamer error: Could not connect to server

while ice cast gives …
/var/log/icecast2/error.log

[2021-03-17  20:31:48] INFO main/main Icecast 2.4.4 server started
[2021-03-17  20:31:48] DBUG yp/yp_recheck_config Updating YP configuration
[2021-03-17  20:31:48] INFO yp/yp_update_thread YP update thread started
[2021-03-17  20:31:48] INFO connection/get_ssl_certificate No SSL capability on any configured ports
[2021-03-17  20:31:49] DBUG slave/_slave_thread checking master stream list
[2021-03-17  20:32:35] EROR connection/_handle_connection HTTP request parsing failed
[2021-03-17  20:32:36] DBUG stats/modify_node_event update global clients (1)
[2021-03-17  20:32:36] DBUG stats/modify_node_event update global connections (1)
[2021-03-17  20:32:36] DBUG stats/modify_node_event update global clients (0)

any help much is appreciated

Any chance you did an upgrade as part of this? The later versions of libshout3 are bugged as per the warning in the docs. What version do you have?

i saw the warning on docs but as it just states the issue is with ubuntu 20.04 i thought it was fine with debian bullseye
i installed ffmpeg to convert my silence.mpeg to silence.ogg, perhaps apt went ahead and upgraded this package as a dependency, i did upgrade latter as it wasn’t working anymore in hope it would fix it
libshout3/testing,now 2.4.5-1+b1 armhf [installed]
any work arround?

already managed to get it back up and working using the deb from the debian buster repo
https://packages.debian.org/buster/libshout3
tysm

I guess I must change the warning to specify the last known working libshout version (v2.4.1). I saw the issue in libshout3 2.4.3-1 and I think the problem was this one. I vaguely remember rebuilding from source and applying a hacky workaround from the Gitlab issue and it worked again. Sorry but I don’t recall exactly what I tried but that is one workaround.

It’s a shame it’s still not fixed and pretty bad news considering new Debian stable is just around the corner. I think we will have to remove the Icecast page entirely and stop suggesting it.

1 Like

OK, that’s another workaround. Thanks for the update.

I’ve added docs: more specifics regarding libshout problem · mopidy/mopidy@f17acac · GitHub

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.