Mopidy Discourse

Mopidy-Spotify + ncmpcpp not working

So I am still very new to Linux so please excuse me if this is a stupid question but the general rule of thumb is usually to search for the problem online and hopefully find a solution before asking but I have read the documentation and used several tutorials as a reference and it still does not seem to work and it has honestly gotten me very frustrated since I’ve spent hours desperately searching for a solution.

Basically opening ncmpccp gives me a ‘connection refused’ error so naturally, I tried running mopidy in the console where it just stays there indefinitely.

INFO     2021-06-18 04:27:50,159 [1042:MainThread] mopidy.__main__
  Starting Mopidy 3.1.1
INFO     2021-06-18 04:27:50,174 [1042:MainThread] mopidy.config
  Loading config from builtin defaults
INFO     2021-06-18 04:27:50,176 [1042:MainThread] mopidy.config
  Loading config from file:///home/ivan2/.config/mopidy/mopidy.conf
INFO     2021-06-18 04:27:50,176 [1042:MainThread] mopidy.config
  Loading config from command line options
INFO     2021-06-18 04:27:50,262 [1042:MainThread] mopidy.__main__
  Enabled extensions: mpd, file, softwaremixer, http, spotify, stream, m3u
INFO     2021-06-18 04:27:50,262 [1042:MainThread] mopidy.__main__
  Disabled extensions: none
INFO     2021-06-18 04:27:50,366 [1042:MainThread] mopidy.commands
  Starting Mopidy mixer: SoftwareMixer
INFO     2021-06-18 04:27:50,367 [1042:MainThread] mopidy.commands
  Starting Mopidy audio
INFO     2021-06-18 04:27:50,368 [1042:MainThread] mopidy.commands
  Starting Mopidy backends: FileBackend, M3UBackend, StreamBackend, SpotifyBackend
INFO     2021-06-18 04:27:50,383 [1042:Audio-2] mopidy.audio.actor
  Audio output set to "autoaudiosink"
INFO     2021-06-18 04:27:50,979 [1042:SpotifyEventLoop] mopidy_spotify.backend
  Logged in to Spotify in online mode
INFO     2021-06-18 04:27:51,809 [1042:SpotifyBackend-6] mopidy_spotify.web
  Logged into Spotify Web API as 4sn78ujo3n9e4dw6s1ul4i24h
INFO     2021-06-18 04:27:59,862 [1042:SpotifyBackend-6] mopidy_spotify.playlists
  Refreshed 13 Spotify playlists
INFO     2021-06-18 04:27:59,863 [1042:MainThread] mopidy.commands
  Starting Mopidy core
INFO     2021-06-18 04:27:59,871 [1042:Core-9] mopidy.core.actor
  Loading state from /home/ivan2/.local/share/mopidy/core/state.json.gz
INFO     2021-06-18 04:27:59,874 [1042:MainThread] mopidy.commands
  Starting Mopidy frontends: HttpFrontend, MpdFrontend
INFO     2021-06-18 04:27:59,876 [1042:HttpFrontend-11] mopidy.http.actor
  HTTP server running at [::ffff:127.0.0.1]:6680
INFO     2021-06-18 04:27:59,878 [1042:MainThread] mopidy_mpd.actor
  MPD server running at [::ffff:127.0.0.1]:6600
INFO     2021-06-18 04:27:59,879 [1042:MainThread] mopidy.commands
  Starting GLib mainloop

I have the same port and hostname for both my mopidy and ncmpccp configs. I have tried running it as a service and have the necessary packages installed such as mopidy-mdp and mopidy-spotify.

My config

[core]
restore_state = true

[mpd]
enabled = true
hostname = 127.0.0.1
port = 6600

[spotify]
enabled = true
username = ivanchristopherB76@gmail.com
password = ******
client_id = (Already inside my config)
client_secret = ******
bitrate = 320

If you all have any solutions please list them down below because I really do not know what else to do

You log shows mopidy has started correctly so if you connect from the same machine to 127.0.0.1:6600 that should succeed. I would not expect Mopidy to log anything else after that point.

Please the deps and config subcommands relevant to the way you are running Mopidy, as per our docs.

Well, what am I exactly to do? I thought I made the parameters clear by setting both the hostname and IP the same in both configs which I’m assuming is the default and is therefore relevant to my machine. Mopidy does not start in general or as a service which does not make mopidy-Spotify work with ncmpcpp. I appreciate your response since I did not expect to see a reply so soon but I really do not know why mopidy does not start and just stays at

First up, decide if you are using either the service or running in your console. Every single time people try and mix them they end up with inconsistent configs and it’s a huge waste of everyone’s time. SO pick one.

Then, for that given method of running Mopidy, provide the output of deps and config. i.e. for the service it’s sudo mopidyctl deps and sudo mopidyctl config.

What do you mean?

So… like I said, Mopidy HAS started correctly in your above log. You then need to connect to Mopidy with a client (such as ncmpcpp) so you can control playing music on the machine Mopidy is running on. Since you have set hostname = 127.0.0.1, you must run Mopidy and ncmpcpp on the same machine. If you want to change that, set hostname = :: and it’ll be accessible from any machine on your network.

Why are you so convinced Mopidy has not started? What more are you expecting?

thanks for the awesome information.