Mopidy service Refuses connection

Hello to everyone,

For the last 2 days i have been searching everywhere for a similar problem and even tryied other solutions, but the problem i have sees to be nowhere.

I have a raspberry pi 2b with mopidy installed and spotify. (i have used PIMusicBox, but it has a lot of features installed that i dont need and it seems to hang the sound from time to time) so i made a fresh install from the start and compiled everything from zero. (im not good with linux and pythong but i made everything work).
I have made the mopidy with mopify web interface, spotify and a usb audio card work. When i start mopidy in the console, works like a charm for days.

But the problem is that when i run it as a service on startup or even in the console, the web interface doesnt work, the web browser (chrome, firefox or edge) says that the raspberry refused the conection. something that when i run it from the console starting mopidy it doesnt happen.

I have tried changing the user that starts the service, from mopidy to pi to root and it doesnt work either, in all the files that i have.

the strange thing is that when i start mopidy by console works for days without a problem. I have done the sudo dkpg-reconfigure mopidy to create the service. and the problem is still there.

If you need something about the configuration i can upload it.

Also if you have any suggestion i will follow it. (i have no problem to test anything as i already have an image of the raspi working so if i destroy something i cant go back).

See you soon. and thanks in advance.