Mopidy Mobile not connecting after server upgrade to Buster

Hello,

after a lot of Googling I unfortunately have no idea what is going on. Maybe someone can help.

I am running mopidy as a service on my Raspberry Pi 3. It runs Raspbian Buster, which I just upgraded to from Stretch. Everything was working before the upgrade, and now I cannot connect from Mopidy Mobile on my phone. Obviously that means I’ve moved from mopidy 2.x to 3.x, which was the point, too.

My /etc/mopidy/mopidy.conf has not changed I believe and it reads as follows:

[core]
cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy
max_tracklist_length = 10000

[logging]
verbosity = 4
config_file = /etc/mopidy/logging.conf
debug_file = /var/log/mopidy/mopidy-debug.log

[local]
media_dir = /media/pi/MUMAK/Musik
enabled = true
library = sqlite
scan_timeout = 3000
scan_flush_threshold = 100
scan_follow_symlinks = false
excluded_file_extensions = 
  .directory
  .html
  .jpeg
  .jpg
  .log
  .nfo
  .png
  .txt

[m3u]
playlists_dir = /var/lib/mopidy/playlists
enabled = true
base_dir = $XDG_MUSIC_DIR
default_encoding = latin-1
default_extension = .m3u8

[local-sqlite]
enabled = true

# top-level directories for browsing, as <name> <uri>
directories =
    Albums                  local:directory?type=album
    Artists                 local:directory?type=artist
    Composers               local:directory?type=artist&role=composer
    Genres                  local:directory?type=genre
    Performers              local:directory?type=artist&role=performer
    Release Years           local:directory?type=date&format=%25Y
    Tracks                  local:directory?type=track
    Last Week's Updates     local:directory?max-age=604800
    Last Month's Updates    local:directory?max-age=2592000

# database connection timeout in seconds
timeout = 10

# whether to use an album's musicbrainz_id for generating its URI
use_album_mbid_uri = true

# whether to use an artist's musicbrainz_id for generating its URI;
# disabled by default, since some taggers do not handle this well for
# multi-artist tracks [https://github.com/sampsyo/beets/issues/907]
use_artist_mbid_uri = false

# whether to use the sortname field for sorting artist browse results;
# set to false to sort according to displayed name only
use_artist_sortname = true

[audio]
mixer = software
mixer_volume = 
output = alsasink
buffer_time = 

[proxy]
scheme = 
hostname = 
port = 
username = 
password = 

[mpd]
enabled = true
hostname = ::
port = 6600
password = 
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist = 
  listall
  listallinfo
default_playlist_scheme = m3u

[http]
enabled = true
hostname = :: ; changed it from original 127.0.0.1
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname
allowed_origins = 
csrf_protection = true

[stream]
enabled = true
protocols = 
  http
  https
  mms
  rtmp
  rtmps
  rtsp
metadata_blacklist = 
timeout = 5000


[softwaremixer]
enabled = true

[file]
enabled = true
media_dirs = /media/pi/MUMAK/Musik ; changed from $XDG_MUSIC_DIR|Music [new line] ~/|Home
excluded_file_extensions = 
  .jpg
  .jpeg
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 3000


[alsamixer]
enabled = true
card = 0
control = Master

[spotify]
username = gustavolarana
password = LGg6121*
client_id = d84d40a2-52e6-4950-8d7d-267a3dd84f71
client_secret = hO9-mbLnUZfCLmn4Iv5Mk74MkUdg16GV4Mnf7KvF_rQ=

It is running OK, as per sudo systemctl status mopidy, which returns

● mopidy.service - Mopidy music server
   Loaded: loaded (/lib/systemd/system/mopidy.service; disabled; vendor preset: enabled)
   Active: active (running) since Mon 2020-04-06 15:53:57 CEST; 32min ago
  Process: 16412 ExecStartPre=/bin/mkdir -p /var/cache/mopidy (code=exited, status=0/SUCCESS)
  Process: 16422 ExecStartPre=/bin/chown mopidy:audio /var/cache/mopidy (code=exited, status=0/SUCCESS)
 Main PID: 16425 (mopidy)
    Tasks: 12 (limit: 2077)
   Memory: 29.1M
   CGroup: /system.slice/mopidy.service
           └─16425 /usr/bin/python3 /usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf

avr 06 15:54:00 raspberrypi mopidy[16425]: INFO     [MainThread] mopidy.commands Starting Mopidy mixer: SoftwareMixer
avr 06 15:54:00 raspberrypi mopidy[16425]: INFO     [MainThread] mopidy.commands Starting Mopidy audio
avr 06 15:54:00 raspberrypi mopidy[16425]: INFO     [MainThread] mopidy.commands Starting Mopidy backends: FileBackend, M3UBackend, StreamBackend, SpotifyBackend
avr 06 15:54:00 raspberrypi mopidy[16425]: INFO     [Audio-2] mopidy.audio.actor Audio output set to "alsasink"
avr 06 15:54:01 raspberrypi mopidy[16425]: INFO     [SpotifyEventLoop] mopidy_spotify.backend Logged in to Spotify in online mode
avr 06 15:54:01 raspberrypi mopidy[16425]: INFO     [SpotifyBackend-6] mopidy_spotify.web Logged into Spotify Web API as gustavolarana
avr 06 15:54:01 raspberrypi mopidy[16425]: INFO     [SpotifyBackend-6] mopidy_spotify.playlists Refreshed 2 Spotify playlists
avr 06 15:54:01 raspberrypi mopidy[16425]: INFO     [MainThread] mopidy.commands Starting Mopidy core
avr 06 15:54:01 raspberrypi mopidy[16425]: INFO     [MainThread] mopidy.commands Starting Mopidy frontends: none
avr 06 15:54:01 raspberrypi mopidy[16425]: INFO     [MainThread] mopidy.commands Starting GLib mainloop

Also, if it helps, running sudo mopidyctl deps yields

Running "/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf deps" as user mopidy
WARNING  [MainThread] mopidy.config Ignoring config section 'mpd' because no matching extension was found
WARNING  [MainThread] mopidy.config Ignoring config section 'local' because no matching extension was found
WARNING  [MainThread] mopidy.config Ignoring config section 'local-sqlite' because no matching extension was found
ERROR    [MainThread] mopidy.internal.log Loading logging config '/etc/mopidy/logging.conf' failed. 'formatters'
Executable: /usr/bin/mopidy
Platform: Linux-4.19.97-v7+-armv7l-with-debian-10.3
Python: CPython 3.7.3 from /usr/lib/python3.7
Mopidy: 3.0.2 from /usr/lib/python3/dist-packages
Mopidy-ALSAMixer: 2.0.0 from /usr/lib/python3/dist-packages
Mopidy-Spotify: 4.0.1 from /usr/lib/python3/dist-packages
GStreamer: 1.14.4.0 from /usr/lib/python3/dist-packages/gi
  Detailed information: 
    Python wrapper: python-gi 3.30.4
    Relevant elements:
      Found:
        uridecodebin
        souphttpsrc
        appsrc
        alsasink
        osssink
        oss4sink
        pulsesink
        id3demux
        id3v2mux
        lamemp3enc
        mpegaudioparse
        mpg123audiodec
        vorbisdec
        vorbisenc
        vorbisparse
        oggdemux
        oggmux
        oggparse
        flacdec
        flacparse
        shout2send
      Not found:
        flump3dec
        mad

When running sudo mopidyctl local scan I get, among other warnings, the following:

ERROR    [MainThread] mopidy.internal.log Loading logging config '/etc/mopidy/logging.conf' failed. 'formatters'

Note I have no idea what formatters is, but it appears above when checking the status with systemctl.

Even with verbosity set to 4 as per the config file, running sudo journalctl -u mopidy does not say much that’s non-trivial, after restarting the service:

-- Logs begin at Mon 2020-04-06 19:18:21 CEST, end at Mon 2020-04-06 19:54:12 CEST. --
avr 06 19:54:09 raspberrypi systemd[1]: Starting Mopidy music server...
avr 06 19:54:09 raspberrypi systemd[1]: Started Mopidy music server.

I’ve done nothing but upgrade from Stretch to Buster, and right after that I have checked this first, and I cannot connect from my phone. I have tried with configuring the connection on the client with port 6600 instead of 6680 of course (which is the default), as per my above config file.