Mopidy installation error

when i enter sudo apt-get install mopidy-spotify
i get the error mopidy-spotify : depends: mopidy (>=2.0) but is installed. E: unable to correct problem, you have held broken package.
how can i fix this error?

Not sure about problem above as I’ve not experienced it - however I find I always need to reboot after installing Mopidy then run sudo apt-get update again ,then install mopidy-spotify. Might be worth trying if you haven’t already done so.

You should not need to reboot.

You need to ensure you have followed all the installation instructions in the documentation i.e.:

  • Added the Mopidy APT repository to your system
  • Run sudo apt-get update

Also note:

The packages are built for:

  • Debian jessie (stable), which also works for Raspbian jessie and Ubuntu 14.04 LTS and newer

i still have wheezy installed. is there any way for this to work on wheezy?

Yes, but only an old version. Wheezy does not have packages for gstreamer1.0 which is required for Mopidy 2.0. To install (the old) version on Wheezy you need wheezy.list

sudo wget -q -O /etc/apt/sources.list.d/mopidy.list

And you should probably consider upgrading to Jessie.

how can i upgrade to jessie? do i need to start over? like installing new os? sorry im new in this so i don’t know much

I know, but since I had problems as mentioned here with not finding mopidy-spotify it runs smoother when I do. :grin:

There are lots of guides online. A summary is at

It might be easier to start from scratch, depends how much you’ve customised your system I guess.

thank you very much sir