Mopidy cannot start with AttributeError: has no attribute "ping"

After upgrading to 1.1.1, mopidy stop working. I run into this error:
running mopidy 1.1.1, install from brew. Mac OS X 10.11.2, running Python 2.7.11. Any suggestions are much appreciated. Thanks

ERROR    2015-12-31 19:04:24,829 [1950:MainThread] mopidy.commands
  Uncaught exception
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/site-packages/mopidy/", line 303, in run
    backends = self.start_backends(config, backend_classes, audio)
  File "/usr/local/lib/python2.7/site-packages/mopidy/", line 386, in start_backends
  File "/usr/local/lib/python2.7/site-packages/pykka/", line 167, in __getattr__
    raise AttributeError('%s has no attribute "%s"' % (self, name))
AttributeError: <ActorProxy for StreamBackend (urn:uuid:43e96d6d-f3de-4370-b9eb-52d843ea5376), attr_path=()> has no attribute "ping"

The method is new in Mopidy 1.1.0. As StreamBackend subclasses Backend it should be present when you run Mopidy 1.1.1. I belive you might be experiencing and have *.pyc files from the previous version still in use. Can you try the workaround described in that issue?

Hi jodal thanks for the suggestion. I just installed mopidy 2.0.0 with Homebrew on my OS X El Capitan and I see the same error as dak when i run mopidy from the command line. I deleted all the *.pyc files and retried again with no success.

Do you have another idea or should I write to the developers on github?

Thanks a lot.

Please make a new topic and include the exact error you get, and we might be able to help.