Mopidy cannot start with AttributeError: has no attribute "ping" [Mac OS X]

I installed Mopidy 2.0.0 according to the installation guide with Homebrew on my Mac OS X 10.11.4 (EL Capitan). The installation was successful and I had to relink one brew formula with brew link afterwards. But when I start Mopidy from the terminal with the command mopidy the console outputs the following error:

$ mopidy
INFO     Starting Mopidy 2.0.0
INFO     Loading config from builtin defaults
INFO     Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend
ERROR    Uncaught exception
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/site-packages/mopidy/", line 307, in run
    backends = self.start_backends(config, backend_classes, audio)
  File "/usr/local/lib/python2.7/site-packages/mopidy/", line 391, in start_backends
  File "/usr/local/lib/python2.7/site-packages/pykka/", line 167, in __getattr__
    raise AttributeError('%s has no attribute "%s"' % (self, name))
AttributeError: <ActorProxy for StreamBackend (urn:uuid:be36db22-6b23-4a77-b130-139b906706e0), attr_path=()> has no attribute "ping"
INFO     Stopping Mopidy frontends
INFO     Stopping Mopidy core
INFO     Stopping Mopidy backends
INFO     Stopping Mopidy audio
INFO     Audio output set to "autoaudiosink"
INFO     Stopping Mopidy mixer

I already tried the method mentioned in this similar topic with no success. I also tried uninstalling and reinstalling Mopidy with no success.

It might be worth checking if you do not also have Mopidy installed via pip.

In addition to, I also seem to recall having to execute pip uninstall mopidy multiple times until pip did not find anything to uninstall. But this was a while ago so I’m foggy on the details.

In fact I think I ended up uninstalling with brew and re-installed Mopidy via pip instead to get it working. But the brew install is required as a starting point to get all of the gst dependencies installed with the correct options.

Thanks a lot for your help. I run pip uninstall mopidy multiple times and then run brew uninstall mopidy. Afterwards I installed Mopidy with pip install mopidy successfully.