Mopidy Discourse

Installation on a Mac - Webclients

Hello,

I’ve installed Mopidy on a Mac following these installation instructions. I have the Mopidy web server page displayed on localhost.

How do I install a Web client so I can manage it from the webui? None of the web clients listed have installations for Mac OS.

I’ve installed Mopidy-Mowecl with sudo python3 -m pip install Mopidy-Mowecl. The installation runs but the client is not displayed. Just the box saying this is where the web clients will be.

Where do I go from here?

Thanks for any pointers.

Install Python pip and python3 and then you can do like on every unix based system something equal to

python3 -m pip install Mopidy-Iris

Thanks,

I’ve installed Mopidy via home-brew without error. The blank Mopidy page was displayed on localhost port 6680.

I ran the installation using the commands you kindly provided. I tried Iris & Mowecl. Now Mopidy won’t run at all. I am getting an error message about GStreamer which I re-installed with home brew. Still won’t work.

This is the error I am getting:
ERROR: A GObject based library was not found.

Mopidy requires GStreamer to work. GStreamer is a C library with a
number of dependencies itself, and cannot be installed with the regular
Python tools like pip.

Please see https://docs.mopidy.com/en/latest/installation/ for
instructions on how to install the required dependencies.

Traceback (most recent call last):
  File "/Users/stevencurren/miniconda3/bin/mopidy", line 5, in <module>
    from mopidy.__main__ import main
  File "/Users/stevencurren/miniconda3/lib/python3.8/site-packages/mopidy/__main__.py", line 7, in <module>
    from mopidy import commands
  File "/Users/stevencurren/miniconda3/lib/python3.8/site-packages/mopidy/commands.py", line 15, in <module>
    from mopidy.audio import Audio
  File "/Users/stevencurren/miniconda3/lib/python3.8/site-packages/mopidy/audio/__init__.py", line 2, in <module>
    from .actor import Audio
  File "/Users/stevencurren/miniconda3/lib/python3.8/site-packages/mopidy/audio/actor.py", line 8, in <module>
    from mopidy.audio import tags as tags_lib
  File "/Users/stevencurren/miniconda3/lib/python3.8/site-packages/mopidy/audio/tags.py", line 7, in <module>
    from mopidy.internal.gi import GLib, Gst
  File "/Users/stevencurren/miniconda3/lib/python3.8/site-packages/mopidy/internal/gi.py", line 5, in <module>
    import gi
ModuleNotFoundError: No module named 'gi'

The reference just directs me back to the installation instructions I have already followed.

Any help appreciated. Thanks.

Also tried:

brew install
gst-python
gst-plugins-base
gst-plugins-good
gst-plugins-ugly

Still will not run.

In the end I think my python environment was screwed up somewhere. I deleted the thing and re-installed and its up and running.

The adventure continues.

Thanks for the assistance.