Mopidy Discourse

I have installed spotify extension but it does not work

i ha installed the spotify extension as i should but
when i run

mopidy

it says this

WARNING  2021-12-06 00:47:49,711 [945447:MainThread] mopidy.__main__
  Found spotify configuration errors. The extension has been automatically disab                                                                                        led:
WARNING  2021-12-06 00:47:49,711 [945447:MainThread] mopidy.__main__
    spotify/username must be set.
WARNING  2021-12-06 00:47:49,711 [945447:MainThread] mopidy.__main__
    spotify/password must be set.
WARNING  2021-12-06 00:47:49,711 [945447:MainThread] mopidy.__main__
    spotify/client_id must be set.
WARNING  2021-12-06 00:47:49,711 [945447:MainThread] mopidy.__main__
    spotify/client_secret must be set.
WARNING  2021-12-06 00:47:49,711 [945447:MainThread] mopidy.__main__
  Please fix the extension configuration errors or disable the extensions to sil                                                                                        ence these messages.

and 

ERROR    2021-12-06 00:47:49,838 [945447:MainThread] mopidy.commands
  Frontend (HttpFrontend) initialization error: HTTP server startup failed: [Err                                                                                        no 98] Address already in use

Running “/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf config” as user mopidy
[core]
cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy
max_tracklist_length = 10000
restore_state = false

[logging]
verbosity = 0
format = %(levelname)-8s [%(threadName)s] %(name)s %(message)s
color = false
config_file =

[audio]
mixer = software
mixer_volume =
output = autoaudiosink
buffer_time =

[proxy]
scheme =
hostname =
port =
username =
password =

[musicbox_webclient]
enabled = true
musicbox = false
websocket_host =
websocket_port =
on_track_click = PLAY_ALL

[iris]
enabled = true
country = NZ
locale = en_NZ
snapcast_enabled = true
snapcast_host = localhost
snapcast_port = 1780
snapcast_ssl = false
snapcast_stream = Default
spotify_authorization_url = https://jamesbarnsley.co.nz/iris/auth_spotify.php
lastfm_authorization_url = https://jamesbarnsley.co.nz/iris/auth_lastfm.php
genius_authorization_url = https://jamesbarnsley.co.nz/iris/auth_genius.php
data_dir = $XDG_DATA_DIR/iris

[file]
enabled = true
media_dirs =
$XDG_MUSIC_DIR|Music
~/|Home
excluded_file_extensions =
.directory
.html
.jpeg
.jpg
.log
.nfo
.pdf
.png
.txt
.zip
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

[http]
enabled = true
hostname = 127.0.0.1
port = 6680
zeroconf = Mopidy HTTP server on $hostname
allowed_origins =
csrf_protection = true
default_app = mopidy

[m3u]
enabled = true
base_dir =
default_encoding = latin-1
default_extension = .m3u8
playlists_dir =

[softwaremixer]
enabled = true

[stream]
enabled = true
protocols =
http
https
mms
rtmp
rtmps
rtsp
metadata_blacklist =
timeout = 5000

[spotify]
enabled = true
username = secret
password = secret
client_id = secret
client_secret = secret
bitrate = 160
volume_normalization = true
private_session = false
timeout = 10
allow_cache = true
allow_network = true
allow_playlists = true
search_album_count = 20
search_artist_count = 10
search_track_count = 50
toplist_countries =

Can anyone help me

You need to use the same config option for both running Mopidy and checking the configuration.

If you’re just using mopidy to run, then mopidy config will show you the configuration applied.
Or you need to pass the same --config option to both commands.

And please read the configuration section for the appropriate running method at Running — Mopidy 3.2.0-3-gb10f3115 documentation