HTTP Server Fails at Boot & GStreamer text/uri-list Problems

Hi there –

I’m having two problems with running Mopidy on Raspberry Pi, and I’ve run out of ideas on debugging. I’d love any assistance:

ISSUE 1: HTTP Server Fails on Boot

On initial boot, I see the following in the mopidy.log file:

INFO [2497:MainThread] mopidy.commands: Starting Mopidy core
INFO [2497:MainThread] mopidy.commands: Starting Mopidy frontends: MpdFrontend, HttpFrontend
INFO [2497:MainThread] mopidy.mpd.actor: MPD server running at [::ffff:0.0.0.0]:6600
ERROR [2286:MainThread] mopidy.commands: Frontend (HttpFrontend) initialization error: HTTP server startup failed: [Errno -9] Address family for hostname not supported

However, if I go to the console and restart the service with “sudo service mopidy restart”, all is fixed:

INFO [2497:HttpFrontend-10] mopidy.http.actor: HTTP server running at [::ffff:0.0.0.0]:6680

I would think that it has something to do with Mopidy trying to start up the front ends before networking is ready… but MPD doesn’t complain with a very similar config, so I’m a bit flummoxed.

ISSUE 2: M3U Playlists from TuneIn Fail to Stream

When I try to start certain streams, I get the following error in the log, and it’s unable to play:

WARNING [2497:MainThread] mopidy.audio.actor: Could not find a text/uri-list decoder to handle media.
WARNING [2497:MainThread] mopidy.audio.gst: There is no codec present that can handle the stream's type.
ERROR [2497:MainThread] mopidy.audio.gst: Your GStreamer installation is missing a plug-in.

An example stream is: http://www.wqxr.org/stream/wqxr/mp3.pls

[Playlist]
NumberOfEntries=1
File1=http://stream.wqxr.org/wqxr
Title1=WQXR New York
Length1=-1

MY SETUP

  • Raspberry Pi 2 Model B, running Raspbian 7.8 Wheezy (Kernel 4.1.6-v7+)
  • Mopidy v 1.1.0 runing as a service.

mopidy.conf (extras removed):

[core]
cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy

[mpd]
enabled = true
hostname = 0.0.0.0
port = 6600
password =
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist = listall, listallinfo

[http]
enabled = true
hostname = 0.0.0.0
port = 6680
zeroconf = Mopidy HTTP server on $hostname

[audio]
output = alsasink

Addition Package Versions (Not All-Inclusive):

  • mopidy (1.1.0-2)
  • mopidy-alsamixer (1.0.3-3)
  • mopidy-soundcloud (2.0.0-2)
  • mopidy-tunein (0.2.2-2)
  • mpg123 (1.14.4-1)
  • mplayer (2:1.0~rc4.dfsg1+svn34540-1)
  • python-gst0.10 (0.10.22-3)
  • python-gst0.10-rtsp (0.10.8-3)
  • gstreamer0.10-alsa:armhf (0.10.36-1.1)
  • gstreamer0.10-ffmpeg:armhf (0.10.13-5)
  • gstreamer0.10-fluendo-mp3 (0.10.15.debian-1)
  • gstreamer0.10-gconf:armhf (0.10.31-3+nmu1)
  • gstreamer0.10-gnomevfs:armhf (0.10.36-1.1)
  • gstreamer0.10-plugins-bad:armhf (0.10.23-7.1+deb7u2)
  • gstreamer0.10-plugins-base:armhf (0.10.36-1.1)
  • gstreamer0.10-plugins-cutter (1.1.7-1.2)
  • gstreamer0.10-plugins-good:armhf (0.10.31-3+nmu1)
  • gstreamer0.10-plugins-ugly:armhf (0.10.19-2)
  • gstreamer0.10-pulseaudio:armhf (0.10.31-3+nmu1)
  • gstreamer0.10-tools (0.10.36-1.2)
  • gstreamer0.10-x:armhf (0.10.36-1.1)

Any ideas? Thanks so much.

This is probably due to https://github.com/mopidy/mopidy/issues/1250, slated for a fix in the upcoming 1.1.1 release.