How to Pi Musicbox with a Raspberry PI B+

Hi Guys,

I was looking for something more handy and ready-to-use regarding to an audiophile distribution for my new Raspberry PI B+.

I went from Volumio but the possibilities didn’t satisfy me. I found Pi Musicbox interesting but nothing was posted about the B+ compatibility.

The only obstacle I came across was the network compatibility with the B+, but I want to share my experience about using Pi Musicbox on my B+.

I do know that if you already have a PI B, you can easily update your existing Pi Musicbox with the latest Raspberry’s package update including the new B+. Then transfer the SD into a MicroSD and enjoy your Pi B+ with Pi Musicbox.

But for people like me who just bought their first Raspberry Pi especially B+, how to manage it ?

I simply downloaded the Pi Musicbox image and made a boot disk on my Micro SD card.
Then, I downloaded the start_x.elf and fixup_x.dat from here:

Finally I replaced the existing start_x.elf and fixup_x.dat on my MicroSD by the new ones.
Everything is running great now, my USB Muse 2704 DAC works perfectly with. After configuring Pi Musicbox via Lan, my Wifi Dongle is recognized perfectly, DLNA / Web Radios / Local Storage are fine.

Hope it will be useful for you guys.
Duncan :wink:

Thanks for your report!

Those files seem to now only be available at

No idea if they work, if someone finds out could they update this thread.

I just put the 0.5 image on a micro SD card and this in my new rpi B+.
everything seems to go fine, Pi boots, get connected, but theres no sound at all.

I want to use the internal soundcard of the Pi - did I miss something? Do I have to configure the Pi anew somehow?


if you have connected a HDMI cable then by default the sound will output over that, otherwise (assuming no other USB soundcards are connected) it will use the Pi’s internal analogue soundcard. You can force using the internal soundcard by setting output = analog in the [musicbox] section of settings.ini.

The B+ also has a different 3.5mm socket and some audio cables don’t work - see

oh - i forgot to solve: the audio cable did the trick. I wasn’t aware of the change in cable for the B+!