Forums not visible on iPhone?!


just lately, I’ve been unable to view on my iPhone - either using Safari or Chrome. The site appears to load but I just get a whitescreen. Anyone else having this problem? I’m sure it didn’t use to happen :confused:


Do you know how long it is since this started happening?

We moved from Cloudflare to Fastly as cache in front of the forum around August 13.

It could well be around that time. I didn’t think that much of it the first few times, but after a while it became a bit of an annoyance. That’s when I tried it on Chrome rather than Safari - same result…I meant to post up before about it but forgot.

Does the same happen on your device?

No, it works properly with Chrome on my Android 5.1 device.

I checked, and we’re running the latest beta version of Discourse: 1.4.0beta10.

Let me know if you can find any error message/indication of what’s wrong. What iOS version do you run? It might be something with the SSL setup.

I’ll try un & reinstalling Chrome, see if that fixes it. iOS 8.4. Not sure how I’d be able to find any error messages, although saying that, the device is jailbroken so I have full file access - will see if there’s a log…

Hmmm…Ok, seems like something strange going on with layout. If I have my iPhone horizontal, nothing - just a white screen. If I turn to landscape, I see this:

But I can’t scroll or select a topic to read.

Just upgraded to a new Discourse release. Maybe that helped?

Fantastic! It certainly did - viewing and posting this on my iPhone :smile:

Great work!