Failed to scan external hard disk on ubuntu

mopidy failed to scan external hard disk connected on ubuntu. here is the screenshot:

munnu@macmini:/mnt$ sudo mopidyctl local scan
Running “/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf local scan” as user mopidy
INFO Starting Mopidy 2.0.0
INFO Loading config from builtin defaults
INFO Loading config from /etc/mopidy/mopidy.conf
INFO Loading config from command line options
INFO Enabled extensions: mpd, http, stream, m3u, softwaremixer, file, local
INFO Disabled extensions: none
WARNING Local media dir /media/munnu/hd does not exist.
INFO Found 0 files in media_dir.
WARNING Encountered 1 errors while scanning media_dir.
INFO Checking 0 tracks from library.
INFO Removing 0 missing tracks.
INFO Found 0 tracks which need to be updated.
INFO Scanning…
INFO Scanned 0 of 0 files in 0s.
INFO Done scanning.
munnu@macmini:/mnt$ cd /media/munnu/hd

as you can see from above the hard disk and folder exits as I just cd into it. Any help ?
Running ubuntu 15.xx


Check the permissions on that folder would be your first step.

Thanks. It was the permission error of the parent folder where the external disk was being mounted. It worked after I added r and x permission for group:other of the parent. But don’t know if this is acceptable from security stand point. But it worked and thanks a million.