/etc/mopidy.conf settings not showing up


I’m trying to configure mopidy.

When I run sudo mopidyctl config I see all of the settings i want to edit but when I try to edit /etc/mopidy.conf (running mopidy as a service) I do not see any of the settings.

First line of output from sudo mopidyctl config
Running “/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf config” as user mopidy

I’ve looked at /etc/mopidy/mopidy.conf and /usr/share/mopidy/conf.d/mopidy.conf

For example I’ve added the Mopidy-Iris web extension and see a section for Iris settings ([iris]) but no section like that in any of the mopidy.conf files.

contents of: /usr/share/mopidy/conf.d/mopidy.conf

This file should not be modified. Everything can be overriden by


cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy

format = %(levelname)-8s [%(threadName)s] %(name)s %(message)s
color = false


Hi, from Configuration — Mopidy 3.2.0-3-gb10f3115 documentation

If you want to keep the default value for a config value, you should not add it to the config file, but leave it out so that when we change the default value in a future version, you won’t have to change your configuration accordingly.

mopidyctl config prints your full effective config. This will be the default values combined with any overrides you add to the config file. If you want to change a particular setting to a non-default value then add it to the config file.

I don’t think I need to mention /usr/share/mopidy/conf.d/mopidy.conf, there is already an extremely clear warning not to modify that file.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.