Autostart modipy don't get it to work


#1

Autostart how to get it to work?

I am flowing the following link below:
https://docs.mopidy.com/en/latest/service/

pi@raspberrypi:~ $ sudo systemctl enable mopidy
Synchronizing state of mopidy.service with SysV service script with /lib/systemd /systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable mopidy
pi@raspberrypi:~ $ sudo systemctl start mopidy
pi@raspberrypi:~ $ sudo systemctl status mopidy
● mopidy.service - Mopidy music server
Loaded: loaded (/lib/systemd/system/mopidy.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2018-01-01 13:45:15 CET; 2 days ago
Main PID: 472 (mopidy)
CGroup: /system.slice/mopidy.service
└─472 /usr/bin/python /usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf

Jan 01 13:45:22 raspberrypi mopidy[472]: WARNING Cannot access Mopidy-Podcast config directory: Permission denied
Jan 01 13:45:22 raspberrypi mopidy[472]: INFO No local library metadata cache found at /var/lib/mopidy/local/library.json.gz. Please run mopidy local scan to index your local music library. If you do not have a local music collecti
Jan 01 13:45:22 raspberrypi mopidy[472]: INFO Loaded 0 local tracks using json
Jan 01 13:45:22 raspberrypi mopidy[472]: INFO Audio output set to "autoaudiosink"
Jan 01 13:45:22 raspberrypi mopidy[472]: INFO Starting Mopidy core
Jan 01 13:45:22 raspberrypi mopidy[472]: INFO Starting Mopidy frontends: IrisFrontend, MpdFrontend, HttpFrontend
Jan 01 13:45:22 raspberrypi mopidy[472]: INFO Starting Iris 3.8.9
Jan 01 13:45:22 raspberrypi mopidy[472]: INFO MPD server running at [::]:6600
Jan 01 13:45:22 raspberrypi mopidy[472]: INFO Starting GLib mainloop
Jan 01 13:45:22 raspberrypi mopidy[472]: INFO HTTP server running at [::ffff:127.0.0.1]:6680


#2

When i start it with modipy its working.

pi@raspberrypi:~ $ mopidy
INFO Starting Mopidy 2.1.0
INFO Loading config from builtin defaults
INFO Loading config from /home/pi/.config/mopidy/mopidy.conf
WARNING /home/pi/.config/mopidy/mopidy.conf has errors, line 60, 62, 91, 97, 98, 111, 112, 113, 114, 115, 116, 117, 118 has been ignored.
INFO Loading config from command line options
INFO Enabled extensions: iris, mpd, http, alarmclock, stream, spotify, m3u, youtube, radio_rough_html, podcast-itunes, local-images, softwaremixer, file, musicbox_webclient, podcast, tunein
INFO Disabled extensions: local
WARNING Found local configuration errors, the extension has been automatically disabled:
WARNING local/media_dir must be set.
WARNING Please fix the extension configuration errors or disable the extensions to silence these messages.
INFO Starting Mopidy mixer: SoftwareMixer
INFO Mixer volume set to 100
INFO Starting Mopidy audio
INFO Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend, TuneInBackend, PodcastBackend, iTunesPodcastBackend, YoutubeBackend, SpotifyBackend
INFO Audio output set to "autoaudiosink"
INFO Starting Mopidy core
INFO Logged in to Spotify in offline mode
INFO Logged in to Spotify in online mode
INFO Starting Mopidy frontends: MpdFrontend, HttpFrontend, IrisFrontend
ERROR Frontend (MpdFrontend) initialization error: MPD server startup failed: [Errno 98] Address already in use
INFO HTTP server running at [::ffff:192.168.2.208]:6680
INFO Starting GLib mainloop
INFO Starting Iris 3.8.9


#3

This is not pimusicbox.


#4

And what are you trying to do? The output from sudo systemctl status mopidy in your first post shows mopidy running. What is “not working” about that?


#5

I like to start mopidy so i can control it with node-red.

When i use the command modipy it’s working! But it will not autostart.


#6

I am assuming node-red wants to talk to Mopidy via HTTP?

You must have different configs.
sudo mopidyctl config and mopidy config will show the configs in use in each case.


#7

Thanks a lot Kingosticks.

Is it possible to copy the config file? So that the config files are the same?
With of the commands can i use to do that?


#8

So back up your /etc/mopidy/mopidy.conf file then try and save your /home/pi/.config/mopidy/mopidy.conf as /etc/mopidy/mopidy.conf then reboot. Or copy and paste everything in /home/pi/.config/mopidy/mopidy.conf into /etc/mopidy/mopidy.conf


#9

Thanks a lot :smile: It’s working Great :sunny: