Airplay/UPNP not discovered by Android Apps

Hi! I am running musixbox 5.1, and I would like to stream from my Android Device to Musicbox. I enabled UPNP and Airplay and tried several Apps, but most of them don’t discover musicbox.

Here is what I tried:

  • Airplay with Streambels --> Worked some times but not always. Not always discovered.
  • Airplay with ToasterCast --> Did not work
  • UPnP with BubbleUPNP --> Did not work.

Did not work means that the device was not discovered.

All test devices were on the same WIFI Network, I am using the router provided by my internet provider (CBN CH6640E)

Do you have any idea what the problem could be?
Thanks for your help!

Did it work for you on earlier versions?

No, it didn’t;

What I did yesterday: I Installed UPNP using this HowTo:

Now it works. But actually I don’t know what the Problem was. Airplay still does not work.

How could I debug this? Is there a way to check if airplay is sending its alive signals? (or how does it do this?) So i would like to find out if there’s something wrong with my network (maybe the router is blocking something?) Or Rapsberry or maybe the apps I tried on Android.

Is anyone else experiencing similar problems or does it work for you with the mentioned apps?