Trying to install from sources on Centos 7.0

Hello,

I try to install Modipy on a Centos 7.O for a day but impossible…

I’ve tried to install from the sources, and my install is in

usr/lib64/python2.7/site-package/modipy

files are there but the commmand

modipy

in terminal return :

-bash: modipy: command not found

Config files are good edited i think… and it’s impossible to access from a

web platform because it can’t start :stuck_out_tongue: . In the installation guide it says to

install Gstreamer, but no one of the packages are existing :’( ( for : )

emerge -av gst-python gst-plugins-bad:0.10 gst-plugins-good:0.10 \ gst-plugins-ugly:0.10 gst-plugins-meta:0.10

So I installed it my way :

sudo yum install gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-ffmpeg

Modipy continue to block me :frowning:

I don’t know what to do now :c

Thanks for any help, have a good day :wink: ++

As mentioned in the GitHub issue before it was closed: it’s spelled “Mopidy”, not “Modipy”. Try using the correct command name, and it’ll hopefully work a bit better :slight_smile:

1 Like

Okay. I feel VERY stupid now hehe :’)

Sooo it effectively answer ( :blush: ) but not exactly as i wanted… :

Traceback (most recent call last):
File “/usr/bin/mopidy”, line 7, in
from mopidy.main import main
File “/usr/lib64/python2.7/site-packages/mopidy/main.py”, line 28, in
from mopidy import commands, config as config_lib, ext
File “/usr/lib64/python2.7/site-packages/mopidy/commands.py”, line 14, in
from mopidy.audio import Audio
File “/usr/lib64/python2.7/site-packages/mopidy/audio/init.py”, line 4, in
from .actor import Audio
File “/usr/lib64/python2.7/site-packages/mopidy/audio/actor.py”, line 8, in
import pygst
ImportError: No module named pygst

I feel a bit confused now :slight_smile: i already saw that ( yeaah i’ve wrote the right command once :stuck_out_tongue: ) but i didn’t found how to install this “pygst” :confused: if i’m good understanding it’s this “Gsteamer” :stuck_out_tongue:

Let’s find out >__<

Thanks for helping and i apologie for my stupidity hehe :slight_smile:

FOR INFO: in the terminal answer, the “main” is a simple main with two “_” before and after it :slight_smile:

Okayyyy i resolved the foirst problem hehe :stuck_out_tongue:

I don’t know why but gstreamer wasn’t good installed, so i just entered :

yum install gstreamer-python

and then i don’t have the error. :slight_smile: i mean not the same :frowning:

I have a problem for the local files :

INFO Disabled extensions: local
WARNING Found local configuration errors, the extension has been automatically disabled:
WARNING local/media_dir must be set.
WARNING Please fix the extension configuration errors or disable the extensions to silence these messages.

here’s my config file “local/media_dir” :

[local]
enabled = true
library = json
media_dir = $XDG_MUSIC_DIR/modipy/local/music_here
data_dir = $XDG_DATA_DIR/mopidy/local/music_here
scan_timeout = 1000
scan_flush_threshold = 1000
scan_follow_symlinks = false
excluded_file_extensions =
.directory
.html
.jpeg
.jpg
.log
.nfo
.png
.txt

i’ve tried

media_dir = $XDG_MUSIC_DIR/modipy/local
data_dir = $XDG_DATA_DIR/mopidy/local

and

media_dir = $XDG_MUSIC_DIR
data_dir = $XDG_DATA_DIR/mopidy/local

nothing change :c
here’s my folder : http://www.noelshack.com/2015-14-1428189238-2015-04-05-01-13-35.png

Thanks for previous help, i hope you know whyyy :c (i’ve chaged rights, they are 777 for modipy, config file and directory “music_here” :stuck_out_tongue:

There’s no relation between the dir that Mopidy is installed in and the media dir. Also, the error you see is a config error, which relates to reading of the config files, not if the actual dir can be found or not. If it can read the config and the dir doesn’t exist, it’ll simply be created.

Use mopidy config to check what’s Mopidy’s view of the config file. Also, the first few lines of output from mopidy should print what config files it finds and uses. If you run mopidy -v, it’ll also print config file locations it checks if exists.

Thanks for answer :smile:

For mopidy config command i get :

[logging]
color = true
console_format = %(levelname)-8s %(message)s
debug_format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s    \n  %(message)s
debug_file = mopidy.log
config_file =

[audio]
mixer = software
mixer_volume =
output = autoaudiosink

[proxy]
scheme =
hostname =
port =
username =
password =

[mpd]
enabled = true
hostname = 127.0.0.1
port = 6600
password =
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist =
  listall
  listallinfo

[http]
enabled = true
hostname = 0.0.0.0
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname

[stream]
enabled = true
protocols =
  file
  http
  https
  mms
  rtmp
  rtmps
  rtsp
metadata_blacklist =
timeout = 5000

[m3u]
enabled = true
playlists_dir = $XDG_DATA_DIR/mopidy

[softwaremixer]
enabled = true

[local]
enabled = false  ; Extension disabled due to config errors.
library = json
media_dir =  ; Must be set.
data_dir = $XDG_DATA_DIR/mopidy/local/music_here
scan_timeout = 1000
scan_flush_threshold = 1000
scan_follow_symlinks = false
excluded_file_extensions =
  .directory
  .html
  .jpeg
  .jpg
  .log
  .nfo
  .png
  .txt

[moped]
enabled = true

So it must be set, yes… now i want to locate config file, it says :

Loading config from /root/.config/mopidy/mopidy.conf

I edited this file as following : (just [local] part)

[local]
#enabled = true
#library = json
media_dir = $XGD_MUSIC_DIR/mopidy/local/
data_dir = $XDG_DATA_DIR/mopidy/local/music_here
#scan_timeout = 1000
#scan_flush_threshold = 1000
#scan_follow_symlinks = false
#excluded_file_extensions = 
#  .directory
#  .html
#  .jpeg
#  .jpg
#  .log
#  .nfo
#  .png
#  .txt

But i still have :

WARNING  2015-04-05 02:28:40,468 [15607:MainThread] mopidy.__main__
  Found local configuration errors, the extension has been automatically disabled:
WARNING  2015-04-05 02:28:40,468 [15607:MainThread] mopidy.__main__
    local/media_dir must be set.
WARNING  2015-04-05 02:28:40,468 [15607:MainThread] mopidy.__main__
  Please fix the extension configuration errors or disable the extensions to silence these messages.

i’ve edited it but it still don’t work, it’s nor comented out… :frowning: for the record, mopidy config shows the same thing that before… few first lines of mopidy command says that config file are

/root/.config/mopidy/mopidy.conf

So i’m supposing to be good… maybe i’m wrong in the entrances at [Local]'s lines?

Thanks for helping :slight_smile:

My config file in WinSCP : http://image.noelshack.com/fichiers/2015/14/1428194644-2015-04-05-02-43-33.png

Edited: Formatted as code (with triple backtick) instead of quotes (with greater-than). -jodal

Can’t see anything wrong here. Just to reiterate:

  • If mopidy prints /root/.config/mopidy/mopidy.conf as the config file in use,

  • And /root/.config/mopidy/mopidy.conf contains:

    [local]
    media_dir = /some/path
    
  • Then mopidy config should show the same media_dir path.

If not, there’s probably something wrong with the syntax in your config file. Try changing another config and see if you can see the change in mopidy config.

I solved the problem by putting directly he directory :

    [local]
    #enabled = true
    #library = json
    media_dir = /usr/lib64/pyton2.7/site-extention/mopidy/local/musi_here
    data_dir = $XDG_DATA_DIR/mopidy/local/music_here
    #scan_timeout = 1000
    #scan_flush_threshold = 1000
    #scan_follow_symlinks = false
    #excluded_file_extensions = 
    #  .directory
    #  .html
    #  .jpeg
    #  .jpg
    #  .log
    #  .nfo
    #  .png
    #  .txt

i’m not really sure about removing the $XGD_MUSIC_DIR

and btw, when i want to play a song from the web interface moped, it show a Gstreamer error in the log in the command prompt… :confused:

I don’t know if it’s linked :slight_smile: thanks for help !