Rompr won't connect

#1

Hi,

I’ve been trying to setup Rompr with mopidy for quite some time now.

https://gyazo.com/9978807de9477b5d87f1a2ef6f21cdb3

This all looks good (to me at least)
I also checked the ports with lsof -i
https://gyazo.com/f70cf92f23608d2fcba71dfe3cca454d

I had another mopidy installation on a linux virtual machine from where I copied the config. It does connect to this one, but it won’t connect to my docker (the vm version is no good because it wouldn’t scan the music files (and it’s less efficient I guess).

Full config file:

[core]
cache_dir = $XDG_CACHE_DIR/mopidy
config_dir = $XDG_CONFIG_DIR/mopidy
data_dir = $XDG_DATA_DIR/mopidy
max_tracklist_length = 10000
restore_state = false

[logging]
color = true
console_format = %(levelname)-8s %(message)s
debug_format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s\n %(message)s
debug_file = mopidy.log
config_file =

[audio]
mixer = software
mixer_volume =
output = autoaudiosink
buffer_time =

[http]
enabled = true
hostname = 192.168.1.15
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname
allowed_origins =
csrf_protection = true

[mpd]
enabled = true
hostname = 192.168.1.15
port = 6600
password =
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist = listall,listallinfo
default_playlist_scheme = m3u

[file]
enabled = true
media_dirs =
$XDG_MUSIC_DIR|Music
~/|Home
show_dotfiles = false
excluded_file_extensions =
.jpg
.jpeg
follow_symlinks = false
metadata_timeout = 1000

[local]
enabled = true
library = json
media_dir = /media
scan_timeout = 1000
scan_flush_threshold = 100
scan_follow_symlinks = true
excluded_file_extensions =
.directory
.html
.jpeg
.jpg
.log
.nfo
.png
.txt

Thanks in advance

#2

Are you sure you want http infront of that ip address, doesn’t rompr use the MPD protocol? It’s either that or is a problem with your docker config, which I can’t help with.

#3

I think there was something wrong with that docker. I built it from a ubuntu docker and that one works just fine :slight_smile: