Restart problem? Unable to get Mopidy-Simple-Webclient to work or Iris to update


#1

Big picture goal: I want a client that will present a grid of playlists on a touchscreen and then play whatever is selected. It needs to be super simple so a kid can use it.

I’m having trouble with my basic installation though. I tried using pip to install Simple-Webclient, and it would never appear in the list of options on the web page. Similarily, Iris complains about begin on 3.8.9. I used both pip -U and the built in update. Both appear the work, but when mopidy is restarted, it is still on 3.8.9.

The system as a whole seems to be running fine. I can select files, add them to a playlist, and play them all without problems. This is an older installation, but I updated it as well using pip.

Here is the start up log from one of the restarts.

Suggestions on what to look for?

Thanks,
Rudy

2018-08-18 13:53:03,021 INFO [6761:MainThread] mopidy.commands: GLib mainloop got SIGTERM. Exiting...
2018-08-18 13:53:03,023 INFO [6761:MainThread] mopidy.commands: Stopping Mopidy frontends
2018-08-18 13:53:03,053 INFO [6761:MainThread] mopidy.commands: Stopping Mopidy core
2018-08-18 13:53:03,060 INFO [6761:MainThread] mopidy.commands: Stopping Mopidy backends
2018-08-18 13:53:03,078 INFO [6761:MainThread] mopidy.commands: Stopping Mopidy audio
2018-08-18 13:53:03,089 INFO [6761:MainThread] mopidy.commands: Stopping Mopidy mixer
2018-08-18 13:53:04,348 INFO [6872:MainThread] mopidy.__main__: Starting Mopidy 2.1.0
2018-08-18 13:53:05,672 INFO [6872:MainThread] mopidy.config: Loading config from builtin defaults
2018-08-18 13:53:05,696 INFO [6872:MainThread] mopidy.config: Loading config from /etc/mopidy/mopidy.conf
2018-08-18 13:53:05,709 INFO [6872:MainThread] mopidy.config: Loading config from command line options
2018-08-18 13:53:05,824 INFO [6872:MainThread] mopidy.__main__: Enabled extensions: mopify, iris, mpd, http, moped, stream, m3u, softwaremixer, file, local-images, local, local-sqlite
2018-08-18 13:53:05,825 INFO [6872:MainThread] mopidy.__main__: Disabled extensions: spotify, touchscreen
2018-08-18 13:53:05,981 INFO [6872:MainThread] mopify: Setup Mopify
2018-08-18 13:53:06,061 INFO [6872:MainThread] mopidy.commands: Starting Mopidy mixer: SoftwareMixer
2018-08-18 13:53:06,071 INFO [6872:MainThread] mopidy.commands: Starting Mopidy audio
2018-08-18 13:53:06,081 INFO [6872:MainThread] mopidy.commands: Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend, LocalBackend
2018-08-18 13:53:06,169 INFO [6872:Audio-2] mopidy.audio.actor: Audio output set to "autoaudiosink"
2018-08-18 13:53:10,659 INFO [6872:MainThread] mopidy.local.library: Loaded 1805 local tracks using json
2018-08-18 13:53:10,788 INFO [6872:MainThread] mopidy.commands: Starting Mopidy core
2018-08-18 13:53:10,888 INFO [6872:MainThread] mopidy.commands: Starting Mopidy frontends: MpdFrontend, HttpFrontend, IrisFrontend, QueueManagerFrontend
2018-08-18 13:53:10,896 INFO [6872:MainThread] mopidy.mpd.actor: MPD server running at [::ffff:192.168.1.2]:6600
2018-08-18 13:53:10,907 INFO [6872:HttpFrontend-10] mopidy.http.actor: HTTP server running at [::ffff:127.0.0.1]:6680
2018-08-18 13:53:10,913 INFO [6872:IrisFrontend-11] mopidy_iris.frontend: Starting Iris 3.8.9
2018-08-18 13:53:10,936 INFO [6872:MainThread] mopidy.commands: Starting GLib mainloop
2018-08-18 13:53:13,377 INFO [6872:MpdSession-13] mopidy.mpd.session: New MPD connection from [::ffff:192.168.1.2]:58912

#2

Got it.

pip was running on Python 3.4 and Mopidy is running on 2.7. I figured this out by searching for Iris and finding it installed in both 2.7 and 3.4 subdirectories. Mopidy that I have runs only on 2.7. So I used “python -m pip” to rerun the pip commands and it worked. This forced pip to run under the default version of python, which is the one /usr/bin/mopidy points to.

Still need a good answer to the first question though. I’d like a grid of playlists that I can select. I may be able to modify the Simple-Webclient to fit that bill… but if anyone knows of another solution…

thanks!
Rudy