Mopidy-Pandora Breaks Installation

Just tried on two different installs and when I run “pip install mopidy-pandora” on a Raspberry Pi I end up with IncompleteRead errors from that point forward.

And the install fails on missing “Python.h”.

Sounds like you need to install the Python development headers. On Debian/Raspbian, install the package python-all-dev:

sudo apt install python-all-dev

I did that later but it had already messed up my “requests” and hosed pip. I ended up removing all “requests*” in /usr/local/lib/Python-2.7/dist-packages and the force reinstalling requests via apt. It seems to be working now and I guess I’ll try to install Pandora again.


Just tried installing again and it made it through but again hosed pip and now pip won’t run again. It is upgrading requests which is what screws it up I believe.

After further evaluation, mopidy-pandora requires requests >=2.5 but upgrading requests to the latest bricks pip pip-1.5 that is from Ubuntu OS. Not sure the proper path to take here. I upgraded requests and it works but now cannot use pip again. I’m afraid to upgrade pip as I think that got me into trouble last time.

OK. Hogging this thread but I got it working. In case anyone has a similar problem, I had to do the following to get pip and Pandora working:

rm -rf /usr/local/lib/python2.7/dist-packages/requests*
apt-get install --reinstall python-requests
apt-get install python-all-dev
pip install --upgrade pip
pip install --upgrade pyasn1
pip install --force-reinstall --upgrade mopidy-pandora
apt-get install gstreamer1.0-plugins-ugly

Think that was everything.