Mopidy on raspbian Jessie doesn't resume after pause

Hi everyone,

I’m currently trying to get Mopidy up and running on a Raspberry Pi 2. For some reason, when I pause a playlist with mpc pause and then try resume with mpc play, it does not work. mpc status reports playing but the time does not advance and there is no sound. All further calls with mpc result in error: Timeout. I have to restart mopidy to be able to listen to anything again.

I also tried using talking to mopidy directly using telnet instead of mpc, with the same result. All files are stored locally on the Pi’s SD card.

Can anyone help me? I put some more detailed information (logs, config, deps, commands) here:


First up, thanks for such a great write-up of your issue, much appreciated.

Have you tried temporarily moving some of the files to the SD card and ruling out any issues with the Samba network share?

Other than that I think we’ll need a debug log to see what’s going on.

The files are on the SD card (they are shared by the Raspberry Pi2, that’s why samba is in the name). The same issue also happens with Spotify (currently disabled).

I’ll try creating a debug log.

Here’s the debug log:

Does this contain the information you need?

Could it be a permissions issue? When I run mopidy as root, play/pause seems to work fine.