Frustrating playback glitchy


#1

Hi,

I love Mopidy except that I keep hitting a bizarre playback issue.

I add a media (stream, mp3 etc) to an empty playlist to play it for instance, I then I add another media to play. What happens is that it restarts the previous (or the first) audio in the playlist. I have to click on the actual media that I want to play multiple times to play what I want. This even happens with other medias in the playlist, I am rarely able to play what I want as soon as I click on the media.

I know some will say it is a client thing but this behavior is consistent across clients like Moped, Mpd clients (ncmpcc, Malp etc), Mopidy mobile, Web gui etc so it is not a client thing as far as I can tell.

I use 2.1.0-2 on Debian testing, outputting to local Pulse.


#2

That does sound bizare. Can you provide a debug log of this behaviour?


#3

I can, but the logs are not anaonymized and making an anon log out of intense Mopidy log is quite a bit work :frowning:

The issue is that it does not happen with every song but every couple other songs seems to hit this isuse. Basically changing song does not change song, same with online stations, same with different clients, including ncmpcpp. I press next or play next by clicking(in any client), the same song that was playing starts from start instead of forwarding to the next song.

I am just trying to see if anyone else has this issue as well. After that I am going to bite the bullet and share my logs here.


#4

Can you provide the exact steps to reproduce using mpc?


#5

See if this makes sense to you. I just loaded a playlist. It started playing the first song, then ran mpc next, as you see next shows the same song again.

As you see couple mpc next changes to next song. No I do not have duplicate songs in the queue.

PC:/opt/xx$ mpc -h 192.168.5.113 -p 6690 next
2-Vagabondi delle stelle
[playing] #4/800   0:00/0:00 (0%)
volume: 19%   repeat: off   random: off   single: off   consume: on 

PC:/opt/xx$ mpc -h 192.168.5.113 -p 6690 next
2-Vagabondi delle stelle
[playing] #3/799   0:00/0:00 (0%)
volume: 19%   repeat: off   random: off   single: off   consume: on 

PC:/opt/xx$ mpc -h 192.168.5.113 -p 6690 next
18-Rhapsody on a Theme of Paganini
[playing] #1/797   0:00/0:00 (0%)
volume: 19%   repeat: off   random: off   single: off   consume: on 

PC:/opt/xx$ mpc -h 192.168.5.113 -p 6690 next
18-Rhapsody on a Theme of Paganini
[playing] #1/796   0:00/0:00 (0%)
volume: 19%   repeat: off   random: off   single: off   consume: on

#6

Here is another issue,

Here it pretends that it is playing the next one (proton radio) but it is still playing “8- The Glade”. It changed the song but it is still stuck in the prev song.

mpc -h 192.168.5.113 -p 6690 play
8-The Glade
[playing] #1/97   3:08/0:00 (0%)
volume: 19%   repeat: off   random: off   single: off   consume: on

mpc -h 192.168.5.113 -p 6690 next
 - Proton Radio
[playing] #1/96   0:00/0:00 (0%)
volume:  9%   repeat: off   random: off   single: off   consume: on

Even the status is wrong . I am %1000 percent it is the same song (8-The Glade), and no not both stations are playing the same song at the same time, checked it already just in case.

mpc -h 192.168.5.113 -p 6690 status
 - Proton Radio
[playing] #1/96   2:51/0:00 (0%)
volume:  9%   repeat: off   random: off   single: off   consume: on

In my view this has nothing to do with the Mpd implementation because both Moped, musicbox_webclient and Mopidy Android have this issue.


#7

I was hoping for the exact steps so I could copy and paste them to reproduce exactly what you are doing. When you say playlist do you mean playlist or tracklist? Exactly what output config setting are you using here?


#8

It does not matter if it is outputting to pulse, at the moment it is outputting to Snapcast. I have the same issue with Pulseaudio and Snapcast.

I just started testing Snapcast setup, at the time of the initial post, it was pulse audio. But like I said, the result is the same. I have the same issue with the playback whether it is Pulse or Snapcast /tmp/fifo

Not sure about the exact steps. I thought I provided that with the mpc steps :frowning:

I load a playlist (with radios in it, but happens with local music playlist to) into the current queue, then I applied the steps you I posted above with mpc.


#9

Put this into your playlist folder, as m3u. Load that into your current queue. It starts the first radio, play it for lke 20 secs, then click on the second radio, also try “next”

#EXTM3U
#EXTINF:0, - TechnoFM
http://centauri.shoutca.st:8154
#EXTINF:0, - Proton
http://protonradio.com:8000/schedule

Like I said you can substitud e with Pulse, same issue’

[audio]
mixer = software
mixer_volume = 20
output = audioresample ! audio/x-raw,rate=48000,channels=2,format=S16LE ! audioconvert ! wavenc ! filesink location=/tmp/snapfifo
buffer_time =

#10

So I created a docker image from scratch that does not use the same config, and I still have this issue :frowning: So this was not a system related thing.


#11

Can some one try what I explained in Frustrating playback glitchy ? It seems like this issue ios very prominent with online radio stuff.


#12

I am almost convinced that Mopidy has some personal issues with streaming online stuff, I am nt getting this glitch playback with local stuff and the reason I have been scratching my head all over here is that , well I listen online radio mostly with it so I keep hitting this issue constantly : (

I guess noone is using Mopidy to listen online radios via .m3u because I am %100 you will have the same mind blowing playback issue that I have here.