* failed to open vchiq instance


#1

I’m running Mopidy with Iris and Musicbox webclient, it appears to load correctly, but as soon as I try and play anything in Iris* I get a red box flash up “Mopidy Websocket Closed” and when looking at the status (sudo systemctl status mopidy) these are the last 4 lines.

Mar 27 21:48:01 raspberrypi mopidy[335]: * failed to open vchiq instance
Mar 27 21:48:01 raspberrypi systemd[1]: mopidy.service: Main process exited, code=exited, status=255/n/a
Mar 27 21:48:01 raspberrypi systemd[1]: mopidy.service: Unit entered failed state.
Mar 27 21:48:01 raspberrypi systemd[1]: mopidy.service: Failed with result ‘exit-code’.

I searched but can’t find any info anywhere.
*Musicbox webclient also stops at the same point - but I don’t get the error message flagged up.

A restart loads everything again, but still won’t play.


#2

I remember something about needing the mopidy user to be a member of both the audio and video groups in the latest versions of Raspbian. Is mopidy in the video group? I don’t think we do that in our debian package.


#3

I don’t know about video group, it’s just a standard setup, latest stretch with desktop, mopidy and snapclient. How would I check?

I think the answer is in this post Mopidy as service crashes and is missing iris extension which I couldn’t find before, however I don’t know how to set the permissions.


#4

I got it to stop crashing by using
sudo adduser mopidy audio
sudo adduser mopidy video
not sure if that was correct, however now it plays but I still can’t get any sound out of it.


(Solved) Mopidy Mobile crashes
#5

As you probably discovered you can see the groups a user is in by running groups <username>.

As to why there is no sound, first stop is a simple config (i.e. NO FIFO) and:
https://docs.mopidy.com/en/latest/installation/raspberrypi/#testing-sound-output
then try a gst-launch example from:
https://docs.mopidy.com/en/latest/audio/
then ensure your soundcard is as expected with aplay -l etc


Mopidy as service, disconnects on playing local track, run on raspbian
#6

I hadn’t, so thanks for pointing me in the right direction.
To solve the original issue I did
‘groups mopidy’ without the ‘’ this showed mopidy was only in the audio group.
So I did
‘sudo adduser mopidy video’ rebooted
and this resolved the crashing problem.

Sound issues could have been anything, aplay /usr/share/sounds/alsa/Front_Center.wav worked fine, but nothing would play when trying
gst-launch-1.0 audiotestsrc ! audioresample ! autoaudiosink

I had already set sound for headphone only.

I’ve finally got it working, it may have been because I had an hdmi lead attached to a monitor, (perhaps there wouldn’t be the same problem in the lite version) or a duff wifi adapter, I’ve now unplugged the hdmi lead and wifi adapter and am using a powerline adapter and its working.

Thanks again for your help.