Mopidy Discourse

Can't see any of my downloaded "deps" under sudo mopidyctl deps

I’m assuming I have something downloaded incorrectly using python2 instead of python3, because my web clients aren’t visible under the localhost browser. I’m not experienced or intelligent enough to figure out how to solve this. When I run sudo mopidyctl deps I see the following:

Running “/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf deps” as user mopidy
/usr/lib/python2.7/dist-packages/mopidy/ext.py:202: PkgResourcesDeprecationWarning: Parameters to load are deprecated. Call .resolve and .require separately.
extension_class = entry_point.load(require=False)
Executable: /usr/bin/mopidy
Platform: Linux-5.4.72-v7±armv7l-with-debian-10.6
Python: CPython 2.7.16 from /usr/lib/python2.7
Mopidy: 2.2.3 from /usr/lib/python2.7/dist-packages
Mopidy-Spotify-Web: 0.3.0 from /usr/local/lib/python2.7/dist-packages
setuptools: 40.8.0 from /usr/lib/python2.7/dist-packages
Mopidy-Spotify>=1.2.0: 3.1.0 from /usr/lib/python2.7/dist-packages
Mopidy>=2.0: 2.2.3 from /usr/lib/python2.7/dist-packages
Pykka>=1.1: 1.2.1 from /usr/lib/python2.7/dist-packages
pyspotify>=2.0.5: 2.0.5 from /usr/lib/python2.7/dist-packages
cffi>=1.0.0: 1.12.2 from /usr/lib/python2.7/dist-packages
requests>=2.0: 2.21.0 from /usr/lib/python2.7/dist-packages
spotipy: 2.16.1 from /usr/local/lib/python2.7/dist-packages
requests>=2.20.0: 2.21.0 from /usr/lib/python2.7/dist-packages
six>=1.10.0: 1.12.0 from /usr/lib/python2.7/dist-packages
Mopidy>=0.19.0: 2.2.3 from /usr/lib/python2.7/dist-packages
Pykka>=1.1: 1.2.1 from /usr/lib/python2.7/dist-packages
requests: 2.21.0 from /usr/lib/python2.7/dist-packages
Mopidy-Youtube: 2.0.2 from /usr/local/lib/python2.7/dist-packages
setuptools: 40.8.0 from /usr/lib/python2.7/dist-packages
pafy>=0.3.35: 0.5.5 from /usr/local/lib/python2.7/dist-packages
Pykka>=1.1: 1.2.1 from /usr/lib/python2.7/dist-packages
requests>=2.2.1: 2.21.0 from /usr/lib/python2.7/dist-packages
Mopidy>=1.0: 2.2.3 from /usr/lib/python2.7/dist-packages
Mopidy-Spotify: 3.1.0 from /usr/lib/python2.7/dist-packages
Mopidy>=2.0: 2.2.3 from /usr/lib/python2.7/dist-packages
Pykka>=1.1: 1.2.1 from /usr/lib/python2.7/dist-packages
pyspotify>=2.0.5: 2.0.5 from /usr/lib/python2.7/dist-packages
cffi>=1.0.0: 1.12.2 from /usr/lib/python2.7/dist-packages
requests>=2.0: 2.21.0 from /usr/lib/python2.7/dist-packages
GStreamer: 1.14.4.0 from /usr/lib/python2.7/dist-packages/gi
Detailed information:
Python wrapper: python-gi 3.30.4
Relevant elements:
Found:
uridecodebin
souphttpsrc
appsrc
alsasink
osssink
oss4sink
pulsesink
id3demux
id3v2mux
lamemp3enc
mpegaudioparse
mpg123audiodec
vorbisdec
vorbisenc
vorbisparse
oggdemux
oggmux
oggparse
flacdec
flacparse
shout2send
Not found:
flump3dec
mad

Here is my mopidy.conf file:

[core]
cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy

[logging]
config_file = /etc/mopidy/logging.conf
debug_file = /var/log/mopidy/mopidy-debug.log

[local]
media_dir = /var/lib/mopidy/media

[m3u]
playlists_dir = /var/lib/mopidy/playlists

[mpd]
enabled = true
hostname = 0.0.0.0
port = 6600

[http]
enabled = true
hostname = 0.0.0.0
port = 6680
static_dir =
zeroconf = Mopidy HTTP Server on $hostname
allowed_origins =
csrf_protection = true
default_app = mopidy

[spotify]
username = my_actual_username
password =*********
client_id = 3fb8dd5a-758a-42c5-aa2c-6d2f80af6059
client_secret = secret_from_spotify
bitrate = 320

[spotify_web]
client_id = 3fb8dd5a-758a-42c5-aa2c-6d2f80af6059
client_secret = VnEDDLRs3d4l_ZPwHfrqUryFj84aRJwIGZ9v_Mdd7cE=
username = my_actual_username
password =*********
bitrate = 320

My systems python is at the newest version (3.7.3-1)

A lot of Linux distributions come with both Python 2 and 3 installed. You’ve got 2.7 and 3.7 and you’ve installed an old version of Mopidy using 2.7. The current version of Mopidy only works on Python 3.

What command did you use to install Mopidy? You need to make sure you’re installing Python 3 pacakges.