Error spotify and soundcloud


Thanks! Works like a charm :slight_smile: didn’t think of that…


No, it still catches me out when upgrading :slight_smile:



Are you able to turn the Snapcast client stream on and off using Home assistant? Or only able to adjust the volume?


No, you can mute it but not stop the stream being sent, why would you want to do that?


Well… mostly to start if it by some reason has stopped. But the pis you have been setting up has been stable?


Do you mean if the Snapserver has stopped sending the stream? or if the Client Pi has crashed?

Yes very, I have B+, Pi3 and Pi0 connected to it, you get a millisecond gap now and again. As long as Snapserver is streaming the Clients pick it up. Even after a reboot, as soon as snapclient is running the music starts.


If the Client has crashed. Well. Then i guess the best is to unplug and plug IT in again… so it gets a restart. I’m gonna have more control of the server since thats om the same as homeassistant.

Do you have them om Wi-Fi? Or cabled? If Wi-Fi, more gaps than cabled?


We are in a basement flat, one one level, built with thick stone walls, so I have a Pi3 which runs Hass, Mopidy and snapserver & client wired into the modem. I use powerline adapters for the other rooms with a wifi access point at the end of it. I couldn’t really say if I get more gapping with wifi or cabled.

In my daughters modern house, with thinner walls and on two levels everything runs wirelessly from the hub in their hallway. I’ve not had any complaints from them about gapping and not noticed any when I’ve been there.


Nice, Sounds like this is is gonna work good. Any experience with orange pi? I just ordered this one:

Too cheap to not try it :stuck_out_tongue: Got wifi too. But I can get it cabled too several places.


I’ve had an Orange Pi One in the cupboard for about a year, you made me take it out and try it. After wasting a day trying to set it up it seems to work quite well. It looks as though it was ‘gstreamer1.0-alsa’ that was missing, once I found that out it works.
Give me a couple of days to write it up and I’ll message you with I did.


Awsome! If it works this multiroom setup Will have a nice price :+1:


Posted details here
You might need to find a different img file but after that it should be much the same.
I haven’t covered wifi as the One doesn’t have it.
Your sound might be easier to set up if you have a built in soundcard, mine was a usb one. Good luck.


Nice! :slight_smile: Looking forward to get mine in the mail to Try.


Works like a charm! I just had to enable the analouge codec in armbian config.

I got a few glitches when running Mopidy and snapserver on the pi. I moved it to my Plex-serverPC running Ubuntu. No glitches yet. Have tried the Opi0 both wired and wireless network. Seem like it works just as good wireless as wired.
Paid around $29 for orange pi zero, the expansion board, case and sd-card. I think thats ok :+1: