Config Issue - only at one parameter


#1

I have an extension and I have a table with the parameters defined.

So in the init module I let my default config file generated and I also do for the schema.

Only for one parameter I get my extension disabled because of:

Found mqfrontend configuration errors, the extension has been automatically disabled:
mqfrontend/keepAlive config key not found.
mqfrontend/keepalive unknown config key. Did you mean keepAlive?

I really do not undestand this…
Btw. my Init section:

[mqfrontend]
enabled=True
keepAlive=60

#2

update: Guess it’s because it’s the only parameter with an Uppercase character ?!


#3

Seems like a trivial experiment to try. Or read the source code.


#4

hmyeah, tried it

def deserialize(self, values):
    """Validates the given ``values`` using the config schema.

    Returns a tuple with cleaned values and errors.
    """
    errors = {}
    result = {}

    for key, value in values.items():
        try:
            result[key] = self[key].deserialize(value)
        except KeyError:  # not in our schema
            errors[key] = 'unknown config key.'
            suggestion = _did_you_mean(key, self.keys())
            if suggestion:
                errors[key] += ' Did you mean %s?' % suggestion
        except ValueError as e:  # deserialization failed
            result[key] = None
            errors[key] = str(e)

I tried to use the debugger - but do not know how to start mopidy in idle…


#5

renamed parameter to keep_alive - now it works fine.
Is this an issue ?


#6

You could argue it is but since that name goes against our coding conventions it’s not something that has come up before.


#7

it makes sense to uphold the naming conventions in the ini file - because it makes life easier.
But it would be nicer to have a correct notification…