Attached New HiFiBerry Dac+ but now MusicBox.local stopped working!

Hi there, hope someone can help. I received a raspberry PI+ for christmas and have attached a HiFiBerry DAC+ to it. Sound works very well from all Airplay devices but ever since I switched the output from AUTOMATIC to DCA+ in the music box settings and rebooted i’ve lost the ability to access MusicBox.Local. I can only play sound via Airplay from my apple devices.

Im running the latest software from the Pi music box website.

Hope there’s an answer out there - I’m very new to this and not entirely sure what I need to do to fix this.

Best regards
Barney

could be related to this:
https://github.com/woutervanwijk/Pi-MusicBox/issues/201

Any news on this? I have exactly the same issue.

root@MusicBox:~# aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

but I can no longer connect to musicbox.local nor via IP…

Hi Bram - no real news I’m afraid.

Actually, a day or so after I posted this message I went back to the Pi and it started the web GUI perfectly - no idea what changed.

Yesterday I changed a few things in settings - rescanning for music files so I could test a few codecs, and got the same issue again after the reboot.

So now back to square one, Airplay and DNLA work flawlessly but web GUI unavailable.

Planning to image the SD card to 5.3 sometime soon and see if it makes a difference.

Barney

Thanks Barney for the quick reply.
For your information: I am using the 5.3 image. So no luck I’m afraid.

Kind Regards,
Bram.

Presumably the Web gui not working is because Mopidy fails to start. Could
you check that. Login and run something like ‘ps aux | grep mopidy’. If you
don’t see it running, take a look for any clues in
/var/log/mopidy/mopidy.log

You are right. This is what I have in the logfile:

2015-01-22 19:41:06,832 - WARNING  Found alsamixer configuration errors, the extension has been automatically disabled:
2015-01-22 19:41:06,835 - WARNING    alsamixer/control must be set.
2015-01-22 19:41:06,837 - WARNING    alsamixer/card must be set. 
2015-01-22 19:41:06,840 - WARNING  Please fix the extension configuration errors or disable the extensions to silence these messages.
2015-01-22 19:41:11,149 - ERROR    Did not find unique mixer "autoaudiomixer". Alternatives are: software

I just wanted to let you know that I managed to get it working :smile:

I changed the /boot/config/settings.ini to these settings which for me made it work (only relevant shown):

# ------------------
# | Audio Settings |
# ------------------
# Because of limitations with some USB-DACs, MusicBox downsamples USB sound to 44k by default. Set to false   to disable.
downsample_usb = false

# Set default output. This overrides the automatic detection (which sets to usb audio if an usb audio device
# is found, else to hdmi (if hdmi is connected at boot), and otherwise just to the analog out)
# i2s (HifiBerry et all) is not detected automatically. Set it here to be able to use it.
# Options: analog, hdmi, usb, hifiberry_dac, hifiberry_digi, hifiberry_dacplus, iqaudio_dac, wolfson (wolfson needs different kernel)
output = hifiberry_dacplus

[audio]
# Set the startup volume of MusicBox
# Values: from 0 to 100
mixer_volume = 43

# --------------------------------------------------------------------------
# | OTHER Settings                                                         |
# | You probably don't want to edit the settings below this line. Really.  |
# | Unless you know what you're doing, or you want to change the webclient |
# --------------------------------------------------------------------------
# This sets the gstreamer buffer. It's a bit tricky...
# If you have problems with stuttering sound, try other values here, like:
# or
#output = alsasink buffer-time=300000 latency-time=20000 
#output = alsasink buffer-time=200000 latency-time=10000
#output = alsasink

#mixer = autoaudiomixer
mixer = software

#optionally, you can use alsamixer. This enables you to use hardware mixers of usb/audiocards.
#Set the previous setting to:
#mixer = alsamixer
#And set the card and contol below. E.g.
#card = 1
#control = Master
#Run the command 'amixer scontrols' from the commandline to list available controls on your system
#See https://github.com/mopidy/mopidy-alsamixer                                                                                                                                                                                            

[alsamixer]
card = 0
control = DSP Program

[stream]
enabled = true
protocols = http, https, mms, file, rtmp, rtmps, rtsp, udp, mmsh

Hi please help I can’t get my digi+ to work either what can I do ? Sorry I’m not computer savvy can someone explain how to get te digi+ to work thanks

Hi Bram can you explain to me in plain English how you got this to work

Hi bram, thanks for the reply, so it’s a problem with the hardware volume mixer?
If tried volomio early and the same problem applies. Once you choose the hi fi berry + you loose control of aspects
Of the GUI. Disabling the hardware mixer fixed everything. Accept volume control ofcourse.
Going back over the forum there are suggestions that drivers need to be updated to allow
Hardware mixer to work. I’d read these before but I was unaware the GUI would be effected
The trouble is I don’t understand where to find or how to effect driver info.
Would anyone know where I locate the drivers and how I enter Sudo commands?

Regards
Barney

Hi gene, on the SD card in the Pi there’s a text file called Settings.ini, take out the card and put into a PC or Mac and open settings.ini in a text editor. Bram has copied the section of the file that he has changed. Repeat his changes, save, place back in the Pi and reboot.
The lines beginning with # are annotated instructions to you the user, so there’s not much to change.

Barney

Hi Barney, Gene,

In fact you can enable ssh access in the settings.ini file. If you reboot with the ssh access enabled, you can access the commandline via some ssh client (ex. Putty - http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html). You can login by entering the ip address of your Raspberry Pi as hostname, using the username ‘root’ with password ‘musicbox’.

You’re free to install your preferred linux text editor and you can start editing the settings file ‘vi /boot/config/settings.ini’ or enter whatever command you like to test your system configuration. You can reboot via commandline by entering ‘reboot now’. It helps if you have some basic Linux skills.

Good luck,
Bram.

Hi Bram thanks for that, i’ll be giving this a try soon. Can I ask, how do
you find the sound quality through Musicbox? I have the HiFiBerry Dac+ and
the sound is as bad as the headphone jack output. Do I need to change
something?

Barney

Hi Barney,

I think in your case something must be wrong than. The sound quality has hugely improved with the DAC+. Maybe you should login via ssh and check the file /var/log/mopidy/mopidy.log to see if you find any clues there. There really should be a noteable difference.

Bram.

@Barnaby_Marshall Does your DAC+ have a headphone jack? If you are using the Raspberry Pi 'phone jack, the sound is pre-DAC so what you are hearing is only the standard terrible Raspberry Pi quality.

There’s a version of the HiFiBerry board that has a headphone jack but no RCA ports, but a phone jack can be soldered onto an RCA DAC+ (voids warranty).